XL 2016 Aides sur les formules de base

RELAX89

XLDnaute Nouveau
Bonjour;
Je débute avec les fonctions d'Excel.
A titre d'exercice, j'essaye de faire un programme de décompte de points de belote.
Exemple : la colonne "B"" contient les scores de l'équipe A et la "D" ceux de l'équipe B. ....(C et E contiennent le score de belote)

En D4 j'ai inscrit la formule suivante : =SOMME(162-B4) ...tout va bien! Sauf :
Si une des équipe fait "Capot" alors le score n'est pas 162 mais 152 car il n'y a pas de "dix de der"
Et ne pas écrire "162" dans la colonne B tant que la manche n'est pas jouée
Quelles sont les formules exactes ?
Idem pour le score final: s que la première qui arrive à 1000 points, inscrire "Gagné!"en cellule B18 ou D18
Merci pour votre aide
Relax89
 

Fichiers joints

ymanot

XLDnaute Junior
Bonjour
Dans votre cas il faut miser sur mise en forme conditionnellle.
"si la cellule contient"
" capot" ecrire " 162"
si la.cellule contient
"1000" ecrire " gagné"
il faudra donc creer une colonne suplementaire pour ces ecritures et masquer la colonne contenant capot et 1000...
cdlt
 

ymanot

XLDnaute Junior
Bonjour
Dans votre cas il faut miser sur mise en forme conditionnellle.
"si la cellule contient"
" capot" ecrire " 162"
si la.cellule contient
"1000" ecrire " gagné"
il faudra donc creer une colonne suplementaire pour ces ecritures et masquer la colonne contenant capot et 1000...
cdlt
il est aussi possible de generer une matrice
avec une recherche V
telle que
capot -- 162
1000 - gagné
...
 

RELAX89

XLDnaute Nouveau
Hello
Merci pour vos réponses.
Comme je l'ai dit dans ma demande d'aide, je débute avec les formules, alors avec les matrices.....:oops:
Le capot c'est 152 et l'équipe adverse a Zéro point.
Vous seriez charitable de m'écrire les formules ou me modifier mon fichier avec un petit tuto ce serait plus parlant pour mon petit cerveau;)
Merci pour votre aide
Relax89
 

RELAX89

XLDnaute Nouveau
Bonjour le Forum,
Bonjour RELAX89, ymanot,

Un essai en fichier joint

Cordialement
Bonjour!
Merci pour ton aide.
J'ai essayé le fichier modifié.
Cela marche si je mets "152" dans la colonne B, la colonne D affiche bien "0"
Sinon, si je mets "152" dans la colonne C rien ne s'affiche dans la colonne B et la formule est effacée!!!
Il faudrait écrire "0" dans la colonne B et afficher "152" dans la colonne C et pas "162" !
(Le "Capot" dans la colonne F n'était là que pour signaler qu'il y avait un capot dans l'exemple!)
Pour le score final, comment indiquer l'équipe gagnante si les deux équipes dépassent les 1000 points en même temps?
Cordialement
 

Jocelyn

XLDnaute Barbatruc
re,

dans le fichier que j'ai envoyé il suffit de mettre 0 en colonne B et capot en colonne F pour avoir 152 en colonne D voir dans le fichier joint précédemment ligne 6 en gros ne rien noter manuellement en colonne D.

pour la derniere demande je regarde et te propose quelque chose

Cordialement
 

Jocelyn

XLDnaute Barbatruc
re,

pour ta dernière question si les 2 équipe passent 1000 en même temps le gagnant sera celui qui a le plus gros chiffre pour cela a mettre en

B18 : =SI(ET(B17>=1000;D17>=1000;B17>D17);"Gagné";SI(ET(B17>=1000;D17<1000);"Gagné";""))
D18 : =SI(ET(B17>=1000;D17>=1000;B17<D17);"Gagné";SI(ET(B17<1000;D17>=1000);"Gagné";""))

Cordialement
 

RELAX89

XLDnaute Nouveau
re,

dans le fichier que j'ai envoyé il suffit de mettre 0 en colonne B et capot en colonne F pour avoir 152 en colonne D voir dans le fichier joint précédemment ligne 6 en gros ne rien noter manuellement en colonne D.

pour la derniere demande je regarde et te propose quelque chose

Cordialement
Hello
OK, mais, peux-t-on éviter d'écrire "capot" dans la colonne F ?
Cordialement
Relax89
 

Jocelyn

XLDnaute Barbatruc
re,

hum je ne voit pas trop dans la mesure ou comme en ligne 11 on peut avoir en colonne B 152 et que ce ne soit pas un capot car 10 points en colonne D après nous ne somme pas obligé d'écrire capot on peut juste mettre un C ou tout autre chose

aprés pour jouer moi même à la belote un capot vaut chez nous 162 puisque pour faire tous les plis il y a bien un pli de der soit le dix de der.

désolé de ne pouvoir faire plus
 

RELAX89

XLDnaute Nouveau
re,

pour ta dernière question si les 2 équipe passent 1000 en même temps le gagnant sera celui qui a le plus gros chiffre pour cela a mettre en

B18 : =SI(ET(B17>=1000;D17>=1000;B17>D17);"Gagné";SI(ET(B17>=1000;D17<1000);"Gagné";""))
D18 : =SI(ET(B17>=1000;D17>=1000;B17<D17);"Gagné";SI(ET(B17<1000;D17>=1000);"Gagné";""))

Cordialement
Hello
OK pour le Total :)
Je vais essayer de décortiquer les formules :rolleyes:
 

RELAX89

XLDnaute Nouveau
re,

hum je ne voit pas trop dans la mesure ou comme en ligne 11 on peut avoir en colonne B 152 et que ce ne soit pas un capot car 10 points en colonne D après nous ne somme pas obligé d'écrire capot on peut juste mettre un C ou tout autre chose

aprés pour jouer moi même à la belote un capot vaut chez nous 162 puisque pour faire tous les plis il y a bien un pli de der soit le dix de der.

désolé de ne pouvoir faire plus
Hello
Autant pour moi, le capot c'est 252 et non 152 !!!!:confused:
 

Fichiers joints

Jocelyn

XLDnaute Barbatruc
re

Oui et aussi autant pour effectivement 252 et la plus besoin de mettre capot en colonne F.

Revoila le fichier

Cordialement
 

Fichiers joints

RELAX89

XLDnaute Nouveau
re

Oui et aussi autant pour effectivement 252 et la plus besoin de mettre capot en colonne F.

Revoila le fichier

Cordialement
Hello!
EXCELLENT, t'es un CHEF !
Petit soucis : au cas ou l'équipe A est dedans, cela ne marche pas.
Cellule B4 =0 .......cellule D4= 252 au lieu de 162 car Excel considère le 0 comme un Capot !
Alors que l'inverse marche!
Cordialement
Relax89
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas