XL 2013 aide sur une formule si

pixpix13

XLDnaute Nouveau
Bonsoir à tous,

Je suis toujours dans mon super planning et pour éviter les erreurs de personnels je cherche à me faire un garde fou, je m'explique:
dans mon service il y'a deux agent qui travaillent de matin , deux d’après midi et deux de nuit.
donc je voudrais au bas de chaque jour de mon planning qu'il me valide si il voit 2 x M 2 x A/M 2 x N

donc j'ai essayé la formule suivante

=SI(NB.SI.ENS(B9:B21;"m"=2;B9:B21;"n"=2;B9:B21;"a/m"=2);"ok";"ko")

mais sans succès , je vous joins un morceau de mon planning anonymiser

Merci de vos aides
 

Fichiers joints

JHA

XLDnaute Barbatruc
Bonjour à tous,

A essayer,
Code:
=SI((NB.SI($B$9:$B$21;"M")&NB.SI($B$9:$B$21;"A/M")&NB.SI($B$9:$B$21;"N"))*1=222;"OK";"KO")
JHA
 

pixpix13

XLDnaute Nouveau
impeccable ça marche Merci beaucoup :):):)

par contre je pense avoir compris pour le & mais pour *1=222 peux tu m'expliquer?
car appliquer sans comprendre c'est ne pas évoluer.
merci de ton aide
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Pour copier la formule sur la droite, il faut modifier les "$" comme suit
Code:
=SI((NB.SI(B$9:B$21;"M")&NB.SI(B$9:B$21;"A/M")&NB.SI(B$9:B$21;"N"))*1=222;"OK";"KO")
Autrement la formule te donne "222" en texte, si tu multiplies par 1 on bascule en numérique.

Tu peux aussi faire comme ça
Code:
=SI((NB.SI(B$9:B$21;"M")&NB.SI(B$9:B$21;"A/M")&NB.SI(B$9:B$21;"N"))="222";"OK";"KO")
copier vers la droite

JHA
 

Denis132

XLDnaute Impliqué
Bonjour Pixpix13, JHA,

Sinon pour une formule qui ressemble plus à la tienne:

=SI(ET(NB.SI(B9:B21;"m")=2;NB.SI(B9:B21;"n")=2;NB.SI(B9:B21;"a/m")=2);"ok";"ko")

@+

Denis
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas