XL 2016 Aide sur formule avec 3 conditions en utilisant option button (menu develop) sans macro

chermiti

XLDnaute Occasionnel
Bonjour le forum,

je veux utiliser une formule en utilisant option button /radio button, dans laquelle elle m'affiche le rang par montant par destination

si je clique sur "ALL" ; elle affiche le rang de toutes les factures; si je clique sur "GCC" ou "ROW"; alors elle affiche uniquement le rang de l'option sélectionnée

merci d'avance
 

Fichiers joints

job75

XLDnaute Barbatruc
Bonjour chermiti,

Voyez le fichier joint et cette formule matricielle en E11 :
Code:
=SIERREUR(GRANDE.VALEUR(SI(ESTNUM(N$4:N$1000);SI((O$4:O$1000=B$10)+(B$10="ALL");N$4:N$1000));LIGNES(E$11:E11));"")
à valider par Ctrl+Maj+Entrée et tirer vers le bas.

A+
 

Fichiers joints

chermiti

XLDnaute Occasionnel
Bonjour chermiti,

Voyez le fichier joint et cette formule matricielle en E11 :
Code:
=SIERREUR(GRANDE.VALEUR(SI(ESTNUM(N$4:N$1000);SI((O$4:O$1000=B$10)+(B$10="ALL");N$4:N$1000));LIGNES(E$11:E11));"")
à valider par Ctrl+Maj+Entrée et tirer vers le bas.

A+
merci beaucoup ça marche
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas