Aide pour une formule, mise en forme conditionnelle et certainement du VBA.

Paulle

XLDnaute Occasionnel
Bonjour à tous,

Dans le fichier, je note les jours de présence par "X".

J'aimerai :

Que dans la cellule AM1, la date de la cellule sélectionnée s'affiche sous la forme de date longue.

Que les cellules étant des dimanches soient remplies d'une couleur. Je n'ai réussi avec la mise en forme conditionnelle.

Savoir pourquoi la formule en AN1 ne fonctionne pas. =SOMME.SI(annee(Dates);AK2;Nbr_jours)
Le mot (annee n'est reconnu comme formule.
 

Pièces jointes

  • Présence01.xlsm
    21.8 KB · Affichages: 8

Paulle

XLDnaute Occasionnel
Bonsoir sylvanu,
Pour le point 1, c'est la cellule activée par un clic sur la plage C2: AG133.
Pour le point 3, je voudrai obtenir l'équivalent des formules en AL.
Dans cette formule, =SOMME.SI(Ans;AK2;Nbr_jours). Je pensai pouvoir remplacer "Ans" par l’extraction de l'année par =SOMME.SI(annee(Dates);AK2;Nbr_jours) et pouvoir supprimer la colonne A (Ans).
Je ne suis pas sure d'avoir été clair.
 

chris

XLDnaute Barbatruc
Bonjour à tous

On ne peut effectuer de transformation sur une plage dans SOMME.SI (que je te conseille d'oublier au profit de SOMME.SI.ENS quel que soit le nombre de critères)

Passe par
VB:
=SOMME.SI.ENS(Nbr_jours;Dates;">="&DATE(AK2;1;1);Dates;"<="&DATE(AK2;12;31))
ou
Code:
=SOMMEPROD((ANNEE(Dates)=AK2)*1;Nbr_jours)
 

Paulle

XLDnaute Occasionnel
Quand je clique sur une cellule dans la zone C2:AG133, la date qui s'affiche en AL1, le mois est bon, le jour c'est toujours "1" et le jour de la semaine n'est pas le bon. Pour aujourd'hui "dimanche 5 juillet 2020", il est affiché "mercredi 1 juillet 2020..

La mise en couleur des cellules ne correspond pas au dimanche.

Merci pour votre aide.
 

Discussions similaires

Statistiques des forums

Discussions
292 869
Messages
1 926 874
Membres
183 296
dernier inscrit
Yaz113