XL 2013 Aide pour une formule matricielle

Victorz

XLDnaute Nouveau
Bonjour :)

Je viens demander de l'aide sur internet car je n'ai trouvé la solution moi même après recherche.

Un shéma vaut mieux qu'un roman, voici mon problème :



Je souhaite faire une formule NB.SI mais j'aimerai stocker dans ma formule un tableau matriciel calculé (ligne des moutons - ligne des chèvres) et compter les cellules qui sont supérieurs à 5.

Enfaîte c'est dans le cadre d'un outil que je développe pour une entreprise et la contrainte c'est que je ne peux pas faire de lignes supplémentaires dans mon fichier (le shéma ci-dessus est juste à titre d'exemple) ni faire cela en VBA.

Ma question : Est-il possible de faire ce traitement avec une formule matricielle et avoir le résultat dans une cellule ? Pouvez-vous m'aiguiller dans la façon de procéder ?

Je vous remercie d'avance,
Victor.
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

A essayer,
Code:
=SOMMEPROD(--(($C$4:$E$4-$C$3:$E$3)>5))
JHA
 

Victorz

XLDnaute Nouveau
Bonjour JHA,

Merci le problème est résolu !

Une autre alternative :

Code:
=SOMMEPROD((((C3:E3)-(C2:E2))>5)*1)
Sujet clos.
Victorz
 

Discussions similaires


Haut Bas