1. Ce site utilise des "témoins de connexion" (cookies) conformes aux textes de l'Union Européenne. Continuer à naviguer sur nos pages vaut acceptation de notre règlement en la matière. En savoir plus.

XL 2013 Aide pour une formule matricielle

Discussion dans 'Forum Excel' démarrée par Victorz, 5 Décembre 2018.

  1. Victorz

    Victorz XLDnaute Nouveau

    Inscrit depuis le :
    5 Décembre 2018
    Messages :
    2
    "J'aime" reçus :
    0
    Bonjour :)

    Je viens demander de l'aide sur internet car je n'ai trouvé la solution moi même après recherche.

    Un shéma vaut mieux qu'un roman, voici mon problème :

    [​IMG]

    Je souhaite faire une formule NB.SI mais j'aimerai stocker dans ma formule un tableau matriciel calculé (ligne des moutons - ligne des chèvres) et compter les cellules qui sont supérieurs à 5.

    Enfaîte c'est dans le cadre d'un outil que je développe pour une entreprise et la contrainte c'est que je ne peux pas faire de lignes supplémentaires dans mon fichier (le shéma ci-dessus est juste à titre d'exemple) ni faire cela en VBA.

    Ma question : Est-il possible de faire ce traitement avec une formule matricielle et avoir le résultat dans une cellule ? Pouvez-vous m'aiguiller dans la façon de procéder ?

    Je vous remercie d'avance,
    Victor.
     
  2. Chargement...

    Discussions similaires - Aide formule matricielle Forum Date
    XL 2013 [résolu] aide formule matricielle Forum Excel 8 Février 2018
    MAC Aide sur formules matricielles Forum Excel 5 Septembre 2016
    [Resolu par Dugenou] Formule matricielle aide Forum Excel 9 Avril 2016
    aide formule matricielle Forum Excel 6 Mars 2016
    aide formule matricielle Forum Excel 1 Décembre 2015

  3. JHA

    JHA XLDnaute Barbatruc

    Inscrit depuis le :
    15 Juillet 2006
    Messages :
    7501
    "J'aime" reçus :
    366
    Sexe :
    Masculin
    Habite à:
    Dunkerque
    Utilise:
    Excel 2013 (PC)
    Bonjour à tous,

    A essayer,
    Code (Text):
    =SOMMEPROD(--(($C$4:$E$4-$C$3:$E$3)>5))
    JHA
     
  4. Victorz

    Victorz XLDnaute Nouveau

    Inscrit depuis le :
    5 Décembre 2018
    Messages :
    2
    "J'aime" reçus :
    0
    Bonjour JHA,

    Merci le problème est résolu !

    Une autre alternative :

    Code (Text):
    =SOMMEPROD((((C3:E3)-(C2:E2))>5)*1)
    Sujet clos.
    Victorz
     

Partager cette page