XL 2013 Aide pour finaliser mon projet fichier chrono

starz

XLDnaute Occasionnel
Bonjour,
Je cherche une âme charitable qui pourrait m'aider à finaliser mon projet de chrono sur excel.
Aujourd'hui j'ai un tableau qui fonctionne mais je souhaiterai ajouter un texte dans mes colonnes de saisies de temps quand le pilote est OUT sauf que après mes formules ne fonctionne plus.
Mon classement qualifications je pense pourrait être amélioré.

Je joins un fichier avec les explications : le tableau AVANT et ce que je souhaite juste en dessous.

D'avance merci
 

Fichiers joints

starz

XLDnaute Occasionnel
j'ai trouvé une partie de la solution ;)
dans la plage J3:N26 il suffisait que je rajoute si.erreur
Code:
=SIERREUR(SI(F3=0;"";--TEXTE(F3/100;"00\:00,00"));"OUT")
Il me manque plus que le classement qui ne me satisfait pas ! une idée pour que ça soit plus propre ?
 

job75

XLDnaute Barbatruc
Bonsoir starz,

Avec le chronométrage au centième de seconde il est peu probable qu'il y ait des ex aequo.

Mais avec cette formule (validée normalement) en O3 c'est absolument sûr :
Code:
=SIERREUR(EXP(LN(MIN(J3:N3)-LIGNE()/"1E12"));"")
J'ai revu aussi les autres formules.

Fichier joint.

A+
 

Fichiers joints

Dernière édition:

starz

XLDnaute Occasionnel
Job75
j'ai une autre petite demande que je viens de rajouter à mon fichier test.
Ajouter des points en fonction du classement.

J'ai tout expliqué dans le fichier joint

d'avance merci et là je suis sur que je suis au bout
 

Fichiers joints

starz

XLDnaute Occasionnel
Re,
J'ai trouvé quelque chose pour avoir les points de 1 à 4.
Par contre pour les 5 points de pénalité, si le pilote est OUT je trouve pas ;)

je colle le code à mettre en K3
Code:
=SIERREUR(SI(J3=0;26;RANG(J3;$J$3:$J$6;1)-NB.SI($A$3:$A$6;0));"-")
 

job75

XLDnaute Barbatruc
Bonjour starz,

Formule en K3 :
Code:
=SI(J3="OUT";5;SIERREUR(RANG(J3;DECALER(J$3;5*ENT((LIGNES(J$3:J3)-1)/5);;4);VRAI);""))
Copier-Collage spécial-Formules sur K3:K26-M3:M26-O3:O26-Q3:Q26-S3:S26.

Formule en X3 :
Code:
=SIERREUR(EXP(LN(SOMME.SI(K$2:S$2;X$2;DECALER(K$2:S$2;EQUIV(W3;T$3:T$26;0);))));"")
à tirer su X3:X22.

Fichier (2).

Edit : petit détail, pourquoi VRAI au lieu de 1 dans la fonction RANG ?

Parce que VRAI ou FAUX prend 1 octet en mémoire, 1 ou 0 prend 2 octets...

Bon j'aurais pu aussi mettre FAUX au lieu de 0 dans EQUIV...

A+
 

Fichiers joints

Dernière édition:

job75

XLDnaute Barbatruc
Re,

Dans le fichier (2) j'ai aussi revu la formule en T3 (Meilleur chrono) :
Code:
=SIERREUR(EXP(LN(MIN(J3;L3;N3;P3;R3)-LIGNE()/"1E12"));"")
A+
 

starz

XLDnaute Occasionnel
MERCI JOB75.
ça fonctionne à merveille. Et moi je suis une quiche moi qui croyait avoir fini.
je viens de me rendre compte que dans les feuilles suivante celle qui concerne la course je n'ai pas pris en compte les OUT enfin ceux qui n'ont jamais fini la course du coup ça me fou le bins.
si tu veux bien continuer l'aventure je joins le fichier.

je tente t'expliquer :
sur le feuille SERIE 1 , 2 et jusqu’à la finale si je met un OUT mon classement devient faux "normal"
mais le plus compliqué est bien là : il faut pouvoir départager les pilotes en cas de OUT qu'ils soient 1 ou 4 au tas. c'est là qu'interviens les points sur la feuille "chrono qualif"
C'est celui qui à le moins de points qui se classe devant l'autre.

si tu regarde dans la feuille "course" tu peux voir comment le classement interviens dans l’évolution de la course.
un exemple le pilote 1 qualifié pour le prochain tour ira en serie2 C8 , le pilote 2 ira en serie 2 C6 , le pilote 3 en serie 1 C5 et le pilote 4 en serie 1 C7 ...
cf ici http://www.thatdroneshow.com/wp-content/uploads/2016/09/multigpbracket.png

autant j'arriverai a me débrouiller avec le classement et un OUT dedans mais prendre les points en considération pour les départager j'en appel a tes compétences.

ci-joint le fichier complet
 

Fichiers joints

job75

XLDnaute Barbatruc
Re,

Désolé, ça devient trop compliqué, je n'ai pas le courage de continuer.

Attention mon post #7 et mon fichier (2) ont été modifiés, je vois que vous n'utilisez pas les bonnes formules, corrigez-les.

A+
 

starz

XLDnaute Occasionnel
Job75
si vous voyer ce message en colonne X "meilleur chrono" si je n'ai que des OUT . Possible d'attribuer un chrono bidon de 03.00,00 en utilisant ta formule?

sinon j'ai réussi à résoudre mon dernier problème mais en prenant les meilleurs temps en compte pas les points ;)

encore merci
 

job75

XLDnaute Barbatruc
Re,
Job75
si vous voyer ce message en colonne X "meilleur chrono" si je n'ai que des OUT . Possible d'attribuer un chrono bidon de 03.00,00 en utilisant ta formule?
Oui, en T3 de mon fichier (2) :
Code:
=SIERREUR(SI((NB(J3;L3;N3;P3;R3)=0)*NB.SI(J3:R3;"OUT");3/1440;EXP(LN(MIN(J3;L3;N3;P3;R3))))+LIGNE()/"1E12";"")
Bonne nuit.
 

job75

XLDnaute Barbatruc
Bonjour starz, le forum,

En fait au lieu de 3/1440 (3 minutes) il est beaucoup mieux de mettre 1 (une journée) :
Code:
=SIERREUR(SI(NON(NB(J3;L3;N3;P3;R3))*NB.SI(J3:R3;"OUT");1;EXP(LN(MIN(J3;L3;N3;P3;R3))))+LIGNE()/"1E12";"")
Et on met les plages T3:T26 et W3:W22 au format nombre personnalisé [>1]"OUT";mm:ss,00

Fichier (3).

Bonne journée.
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas