Aide avec Sommeprod mois + année [Résolu par Modeste geedee]

subirubi

XLDnaute Occasionnel
Bonjour Forum,

Je bute sur une formule qui pourrait m'aider à me donner le nombre de récurrence d'une donnée pour un mois et une année donnés.

J'utilise cette formule:
VB:
=SOMMEPROD(('Suivi candidatures'!$E$3:$E$234="AB")*('Suivi candidatures'!$N$3:$N$234="Embauche")*(MOIS(mois)=COLONNE(A13))*(ANNEE(année)=2017))
Mais elle me retourne #VALEUR!

Je n'arrive pas à corriger l'erreur.

Merci.
 

Fichiers joints

Modeste geedee

XLDnaute Barbatruc
Bonjour Forum,

Je bute sur une formule qui pourrait m'aider à me donner le nombre de récurrence d'une donnée pour un mois et une année donnés.

J'utilise cette formule:
VB:
=SOMMEPROD(('Suivi candidatures'!$E$3:$E$234="AB")*('Suivi candidatures'!$N$3:$N$234="Embauche")*(MOIS(mois)=COLONNE(A13))*(ANNEE(année)=2017))
Mais elle me retourne #VALEUR!

Je n'arrive pas à corriger l'erreur.

Merci.
Sommeprod fonctionne avec des plages de dimensions identiques !!

la plage Mois ( colonne entiere !!!)contient des N° de mois et non des dates,
la fonction MOIS appliquée sur des valeurs qui ne sont pas des dates renvoie des valeurs erronées
la plage contient des valeurs d'erreur

même remarques pour la plage Année
 

subirubi

XLDnaute Occasionnel
Bonjour forum, Modeste geedee,

J'ai réglé mon problème grâce à vos conseils éclairés.

Ma nouvelle formule:
VB:
=SOMMEPROD(('Suivi candidatures'!$E$3:$E$232="AB")*('Suivi candidatures'!$N$3:$N$232="Embauche")*(MOIS('Suivi candidatures'!$P$3:$P$232)=COLONNE(A$23))*(ANNEE('Suivi candidatures'!$P$3:$P$232)=2017))
Merci bien.
 

Discussions similaires


Haut Bas