afficher message vbcritical quand une cellule n'est pas saisie

atc

XLDnaute Junior
Bonjour forum
j'ai un tableau de saisie et je me demande s'il est possible d'y inserer une macro permettent d'afficher un message lorsqu'une cellule se trouvant
a droite d'une autre cellule contenant la valeur "A" n'est pas saisie
Mon cas par exemple:
sur la plage AJ9:AJ70 La valeure des cellules peut etre égale à "A" j'aimerais
dans ce cas forcer l'utilisateur a remplir la cellule voisine.

merci d'avance
 

atc

XLDnaute Junior
Re : afficher message vbcritical quand une cellule n'est pas saisie

Bonjour forum
Bonjour ERIC S
Merci pour le fil j'avais deja consulté mais ca ne resout mon probleme qu'a moitié puisque mon souci c'est de garantir la saisie de la cellule,le fil c'est pour empecher la saisie par erreur
merci quand meme
@+
 

ERIC S

XLDnaute Barbatruc
Re : afficher message vbcritical quand une cellule n'est pas saisie

re

tu peux empêcher de saisir "A" si la cellule d'à côté est vide...

sinon autre possibilité par macro, tu ne forces pas la saisie mais tu avertis
exemple A en colonne B, remplir colonne A

en C, rouge, gras
=SI(SOMMEPROD(ESTVIDE(A2:A4)*(B2:B4="A"));"Saisir les valeurs en colonne A";"")

avec MFC en A fond rouge si vide et B ="A"
tu sélectionnes ta zone (ex A3:A100)
format mise en forme conditionnelle,
la formule est
=ET(ESTVIDE(A3);B3="A")

sinon pour forcer, ce serait par macro en jouant sur le verrouillage de cellules par exemple

A+
 

atc

XLDnaute Junior
Re : afficher message vbcritical quand une cellule n'est pas saisie

RE
Merci je teste et je vous tient au courant
@+
 

atc

XLDnaute Junior
Re : afficher message vbcritical quand une cellule n'est pas saisie

RE ERIC S
c'est exactement ce que je cherchai merci bcp c'est la derniere soluce qui me convient
@+ et bonne continuation
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas