XL 2010 Afficher contenu d'une cellule si la valeur d'une cellule se situe entre 0 et 12

Gervais

XLDnaute Nouveau
Bonjour à tous

Si la cellule i43 contient un nombre entre 0 et 12 je veux afficher la cellule h43. Mais si la cellule i43 est vide ou supérieur à 12 je ne veux rien afficher

J’ai écrit cette formule

=SI(ET(I43>=0;I43<=12);H43;"")

Ça fonctionne mais si la cellule I43 est vide çà affiche quand même le contenu de la cellule H43

Merci pour votre aide
 

Marcel32

XLDnaute Accro
Bonjour,

On peut aussi utiliser un mélange des deux formules afin de traiter un éventuel cas de valeur négative en I43.
Ce qui peut donner quelque chose comme ceci :
=SI(I43="";"";SI(ET(I43>=0;I43<=12);H43;"") )
 

Marcel32

XLDnaute Accro
Effectivement, si tu ne peux pas avoir une valeur négative en cellule I43, alors elle suffit et convient parfaitement. ;)
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas