XL 2016 additionner les chiffres du mois en cours et des mois precedents

neim

XLDnaute Junior
Bonjour,

Je n'arrive pas à solutionner mon probleme malgres plusieurs essais et recherche.

Je voudrais additionner en feuille 2 tous les chiffre de la collone "D" de la feuille 1 qui sont du mois en cours et des mois precedent (colonne B)

Pourriez vous m aider svp ?

Cordialement,
 

Fichiers joints

Dugenou

XLDnaute Barbatruc
Supporter XLD
Bonjour,
Quand tu dis "mois en cours" : jusqu'à la fin du mois en cours ou jusqu'à aujourd'hui ?
Je vais commencer simple : jusqu'à aujourd'hui : =SOMME.SI(B2:B32;"<="&AUJOURDHUI();D2:D32)
Cordialement
 

WTF

XLDnaute Occasionnel
Ou en formule matricielle :

=SOMME((Feuil1!$D$2:$D$32)*(MOIS(Feuil1!$B$2:$B$32)<=MOIS(AUJOURDHUI())))

Faire Ctrl+Maj+Entrer pour activer la fonction
 

neim

XLDnaute Junior
merci à tous pour vos contributions :)

effectivement, la solution la plus adapté pour moi est celle de AlgoPlus =SOMMEPROD((ANNEE(Feuil1!B2:B32)=ANNEE(AUJOURDHUI()))*(MOIS(Feuil1!B2:B32)<=MOIS(AUJOURDHUI()))*(Feuil1!D2:D32))

En esperant que ceci serve à d'autres...encore merci
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas