additionner le résultat des cellules contenant la fonction SI

mignonchichi

XLDnaute Nouveau
Bonjour,

Novice, j'ai effectué la formule suivante :

=SI(C2>500;"4";SI(C2>=500;"2";"0"))

le résultat de cette formule se trouve dans une colonne (Q2)

j'ai copié cette formule sur 250 lignes de mon tableau.

Maintenant je souhaite additionner le résultat final du nombre de 4 ou de 2.

Si j'utilise la fonction =somme(q2;q253) le résultat donne 0.
Par contre si j'utilise la fonction =somme(q2+q3+q3+) cela fonctionne. mais cela m'embête de taper mes 250 ligne à la suite q4,q4,...q10

aidez-moi

Mon deuxième problème est sur la meme formule mais le résultat est "BACHE" ou "-"
=SI(C2>500;"BACHE";SI(C2>=500;"BACHE";"-"))

la souhaite obtenir le nombre total de mes bâches !

Merci.
 

jeanpierre

XLDnaute Barbatruc
Re : additionner le résultat des cellules contenant la fonction SI

Bonsoir mignonchichi et Bienvenue sur le forum XLD,

Pour la première, par exemple : =NB.SI(A1:A250;4), pareil pour le 2...

Pour la seconde, je ne comprends pas trop.

A te lire.

Jean-Pierre
 

thomlau

XLDnaute Occasionnel
Re : additionner le résultat des cellules contenant la fonction SI

Bonsoir mignonchichi, le Forum

=NB.SI(Q2:Q253;"4")
En faire de même avec le "2". Si ça ne tenait qu'à moi, j'ôterais les " ".

En espérant d'avoir aidé, bonne soirée
 

bhbh

XLDnaute Barbatruc
Re : additionner le résultat des cellules contenant la fonction SI

Bonsoir,

pourquoi deux conditions quasi-identiques, dans la même formule :

Code:
SI(C2>500......SI(C2>=500
soit C2 est supérieur à 500, soit supérieur ou égal à 500....

ensuite, au lieu de mettre les chiffres entre guillemets, met-les en dur...pour qu'excel les considère comme des chiffres...

Avec ta formule :

Code:
=SI(C2>500;4;SI(C2>=500;2;"0"))
pour dénombrer le nombre de 4 ou de 2, utilise la fonction NB.Si

Code:
=NB.SI(D2:D400;2)
si tes données sont de D2 à D400

tout pareil pour les "Bâches", sauf que là, il faut garder les guillemets....

Bon courage...

Pour plus, joins un fichier exemple...

Pfiouuuuuu, suis à la bourre..
Bonsoir, Jeanpierre et soenda
Thomlau, bien content de te revoir, et bonsoir aussi, bien sûr
 
Dernière édition:

soenda

XLDnaute Accro
Re : additionner le résultat des cellules contenant la fonction SI

Bonjour le fil, mignonchichi

La 1ère formule sans les guillemets
Code:
=SI(C2>500;4;SI(C2>=500;2;0))
Et pour le nombre de baches
Code:
=NB.SI(Q2:Q253;"BACHE")
A plus

Edition : Oups ...
 

bhbh

XLDnaute Barbatruc
Re : additionner le résultat des cellules contenant la fonction SI

Re,

tu n'as pas tout lu, dans ma réponse....

tout pareil pour les "Bâches", sauf que là, il faut garder les guillemets....
ta formule en E197 :

Code:
=NB.SI(E3:E196;"BACHE")
 

mignonchichi

XLDnaute Nouveau
Re : additionner le résultat des cellules contenant la fonction SI

Re,

tu n'as pas tout lu, dans ma réponse....



ta formule en E197 :

Code:
=NB.SI(E3:E196;"BACHE")
Oui j'ai bien lu et le résultat donne 0 et non le nombre de bâche contenu dans les cellules E3 à E196.

Je veux dans E196 : X baches
 

JCGL

XLDnaute Barbatruc
Re : additionner le résultat des cellules contenant la fonction SI

Bonjour à tous,

Pour du numérique, tu ne mets pas les " "
Pour de l'alphabétique, il faut mettre les " " pour dire à Excel que c'est du texte

A+ à tous
 

jeanpierre

XLDnaute Barbatruc
Re : additionner le résultat des cellules contenant la fonction SI

Bonsoir,

"Je veux dans E196" : X baches, alors essaie :

La formule : =NB.SI(E3:E196;"BACHE") fonctionne, ensuite :

Dans Format/Cellules/Personnalisé : 0_ " baches"

Bonne soirée.

Jean-Pierre
 

bhbh

XLDnaute Barbatruc
Re : additionner le résultat des cellules contenant la fonction SI

Re,

Re, à tous

Code:
Oui j'ai bien lu et le résultat donne 0 et non le nombre de bâche contenu dans les cellules E3 à E196.
Ah bon?.....
 

Fichiers joints

Discussions similaires


Haut Bas