XL 2013 Additionner des cellules avec des nombres et du texte

B54

XLDnaute Nouveau
Bonjour,

Est-ce possible de faire l'addition de plusieurs cellules qui contiennent un nombre et du texte dans la même cellule.

Ex : faire la somme de

35 minutes
45 minutes
10 minutes
5 minutes

Total : 95

Quand j'exécute la formule somme dans excel j'ai un 0 car j'ai du texte dans ma cellule. Comment additionner seulement les nombres.
 

R@chid

XLDnaute Barbatruc
Re : Additionner des cellules avec des nombres et du texte

Bonsoir et Bienvenue sur XLD,
Si tes données se situent dans la plage A1:A4 :
Code:
=SOMMEPROD(CNUM(GAUCHE(A1:A4;TROUVE(" ";A1:A4)-1)))

@ + +
 

B54

XLDnaute Nouveau
Re : Additionner des cellules avec des nombres et du texte

Merci

Sa fonctionne mais dans mon champ de calcul j'ai également des cellules vides. Quand je fais la formule et je rencontre une cellule vide la réponse est "#valeur!". Si je sélectionne les cases où il y a du contenu la formule fonctionne. Comment ajuster la formule pour qu'elle me donne la somme même si elle rencontre une cellule vide?
 

DoubleZero

XLDnaute Barbatruc
Re : Additionner des cellules avec des nombres et du texte

Bonjour, B54, R@chid :D, le Forum,

Une suggestion avec le code suivant :

Code:
Option Explicit
Sub Nombres_de_a_extraire_vers_b()
' Code de MichelXld (merci !)
    Dim i As Byte, j As Byte
    Dim Cell As Range
    Dim Cible As String
    Dim Nombre As Double, Total As Double
    For Each Cell In Range("A1:A" & Range("A65536").End(xlUp).Row) ' colonne adapter
        Cible = Cell
        j = 0
        i = 0
        Cible = Application.Substitute(Cible, ",", ".")
        Cible = Application.Substitute(Cible, " ", "x")
        For i = 1 To Len(Cible)
            If IsNumeric(Mid(Cible, i, 1)) Then
                j = j + 1
                Cell.Offset(0, j) = Val(Mid(Cible, i, Len(Cible) - i + 1))
                i = i + Len(Str(Cell.Offset(0, j))) - 1
            End If
        Next i
    Next Cell
End Sub
A bientôt :)
 

JHA

XLDnaute Barbatruc
Re : Additionner des cellules avec des nombres et du texte

Bonjour à tous,

Pour compléter la réponse de R@chid que je salue:), un essai avec somme si en matricielle
Code:
=SOMME(SI(ESTTEXTE(A1:A5);CNUM(GAUCHE(A1:A5;TROUVE(" ";A1:A5)-1))))
JHA
 

R@chid

XLDnaute Barbatruc
Re : Additionner des cellules avec des nombres et du texte

Bonjour,
Salut 00, Salut JHA,
mais cher ami c’était pas dans la question.
une autre formule :
Code:
=SOMME(SIERREUR(CNUM(GAUCHE(A1:A10;TROUVE(" ";A1:A10)));))
@ valider par Ctrl+Shift+Enter


@ + +
 

R@chid

XLDnaute Barbatruc
Re : Additionner des cellules avec des nombres et du texte

Re,
ou bien pour eviter la validation matricielle :
Code:
=SOMMEPROD(CNUM(GAUCHE(A1:A9&"0 ";TROUVE(" ";A1:A9&"0 ")-1)))

@ + +
 

B54

XLDnaute Nouveau
Re : Additionner des cellules avec des nombres et du texte

Merci R@chid la formule fonctionne!


Mais je viens de voir un nouveau problème apparaître. Voici le contexte. J’utilise des données provenant d’un formulaire concernant un sondage sur les saines habitudes de vie. Dans mon formulaire pour répondre à la clientèle je me dois d’être précis, concis et utiliser un langage pour les jeunes. Donc je viens de remarquer que je mélange des heures et des minutes dans la même colonne. Idéalement, j’aimerais que mes résultats additionnés apparaissent seulement en heure. Est-ce possible?


45 minutes
1 heure
2 heures
30 minutes
3 heures
1 heures
30 minutes
30 minutes

J'aimerais que la formule me donne la réponse en heure seulement.
 

eddy1975

XLDnaute Occasionnel
Re : Additionner des cellules avec des nombres et du texte

Bonjour,

Pour afficher les minutes en heures il faut utiliser le centième heure.

1/4 d'heure : 0.25
1/2 heure : 0.50
3/4 heure : 0.75
1 heure : 1

@+
 

R@chid

XLDnaute Barbatruc
Re : Additionner des cellules avec des nombres et du texte

Re,
une formule matricielle :
Code:
=SOMME(SIERREUR(GAUCHE(A1:A10;TROUVE(" ";A1:A10)-1)*(ESTNUM(CHERCHE("m";A1:A10))+60*ESTNUM(CHERCHE("h";A1:A10)));))/1440
@ valider par Ctrl+Shift+Enter

Mettre la cellule au format heure.


@ + +
 

B54

XLDnaute Nouveau
Re : Additionner des cellules avec des nombres et du texte

Merci Eddy mais dans ma cellule il y a vraiment 45(nombre) et minutes (texte) ou 1(nombre) et heure (texte0 si tu as une fonction pour changer automatiquement mais minute en heure en tenant compte des paramètres je serais heureux.

Merci R@chid mais la formule me donne 0.

Donc deux contraintes.

1- texte avec nombre (nous avons réglé cette situation)
2- faire le calcul total des heures dans une colonne quand nous avons des heures et des minutes dans la forme de notre contrainte 1

Je sais je pourrais changer mon formulaire pour faciliter le calcul, mais je risque d'avoir des incompréhensions des jeunes.

Merci de votre collaboration. Je suis nouveau sur le forum, j'apprécie vraiment la collaboration!
 

R@chid

XLDnaute Barbatruc
Re : Additionner des cellules avec des nombres et du texte

Re,
Sans fichier je ne pourrais pas deviner d’où vient le problème.
voir PJ


@ + +
 

Fichiers joints

eddy1975

XLDnaute Occasionnel
Re : Additionner des cellules avec des nombres et du texte

Re,

Merci R@chid pour le fichier, c'est plus facile pour trouver une solution.

A voir pour l'histoire des minutes en heure en colonne B.
 

Fichiers joints

gosselien

XLDnaute Barbatruc
Re : Additionner des cellules avec des nombres et du texte

Bonjour,

Est-ce possible de faire l'addition de plusieurs cellules qui contiennent un nombre et du texte dans la même cellule.

Ex : faire la somme de

35 minutes
45 minutes
10 minutes
5 minutes

Total : 95

Quand j'exécute la formule somme dans excel j'ai un 0 car j'ai du texte dans ma cellule. Comment additionner seulement les nombres.
Bonjour,

pourquoi ne pas encoder en minutes directement ?
00:35:00 - 00:10:00 etc etc...

P.
 

B54

XLDnaute Nouveau
Re : Additionner des cellules avec des nombres et du texte

Merci eddy1975!!!! Sa fonctionne très bien!!!!!!!!!!!
 

eddy1975

XLDnaute Occasionnel
Re : Additionner des cellules avec des nombres et du texte

Re,

N'oublie pas R@chid, il a fait le fichier à ta place et trouver la formule plus difficile que la solution que je t'ai proposé.

La prochaine fois post un fichier stp.
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas