Office 365 Additionner cellules avec conditions

ABDELHAK

XLDnaute Occasionnel
Bonjour le forum,
J’aimerais votre aide pour réaliser une nouvelle macro.
La colonne C contient des chiffres.
La macro devra exécuter des additions en commençant par la dernière cellule.
Toutefois il y a une condition, les résultats des additions devront être compris entre 17 (au minimum) et 37 (au maximum). Le résultat idéale étant 27.
Le but est que la macro trouve un maximum d’additions dont le résultat = 27.
Ce chiffre idéale peut changer.
Merci d’avance pour votre aide.
ABDELHAK.
 

Fichiers joints

mapomme

XLDnaute Barbatruc
Supporter XLD
Re,

En fait, en toute logique, il faut mettre la formule suivante en D2026:
VB:
=SI(SOMME(C2026:C$2027)-SOMME(D2027:D$2027)+C2025>27;SOMME(C2026:C$2027)-SOMME(D2027:D$2027);"")
puis la recopier vers le haut jusqu'en D3.
 

ABDELHAK

XLDnaute Occasionnel
Bonjour mapomme,

Désolé pour cette réponse tardive. En effet, j'ai du "apprivoiser" votre 2ième formule.
Elle fonctionne parfaitement bien et de plus je peux changer le chiffre idéal. C'est juste magnifique.
Un seul regret, je sais adapter la formule mais je ne comprends pas la procédure en elle-même.
En tout cas, merci pour votre aide.
A+

ABDELHAK
 
Haut Bas