XL 2016 addition des chiffres a droite

phil77

XLDnaute Junior
bonjour

j essaye d additionner des chiffres qui sont a droite d un égal
en A1" 125*2=250
en B1" 148*2=296
en c1" 200*3=600

je souhaiterais avoir en D1 "1146"

merci au forum
 

Chris401

XLDnaute Accro
Bonjour
Essaye avec la formule matricielle (validation avec ctrl+maj+entrée) :
Code:
=SOMME(1*DROITE(A1:C1;NBCAR(A1:C1)-CHERCHE("=";A1:C1)))
 

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour phil77,

Dans un premier je voudrais juste te dire qu'il est plus simple pour nous d'aider si vous joignez un petit fichier exemple

Après voir en fichier un essai pour répondre a ta demande

2 solutions différentes selon tes données

Cordialement

EDIT Bonjour Chris 401

EDIT 2 pour le fun une autre solution qui fonctionne dans tous les cas de figure sans passé par le sommeprod ()

formule simple

Code:
=SOMME(INDEX(STXT(A7:A9;CHERCHE("=";A7:A9)+1;99)*1;;))
 

Fichiers joints

Dernière édition:

Jocelyn

XLDnaute Barbatruc
Re,

Oui le valeur en C8 était pour te montrer que la première formule génère une érreur si du n'as pas 3 chiffre après le = par contre tu peux utiliser la formule que j'ai mis dans le corp du message qui elle va gérer correctement

Cordialement
 

job75

XLDnaute Barbatruc
Bonsoir phil77, Chris401, Jocelyn,

Pas compris pourquoi Chris401 n'utilise pas SOMMEPROD qui évite la validation matricielle :
Code:
=SOMMEPROD(--STXT(A1:C1;TROUVE("=";A1:C1)+1;9^9))
A+
 

phil77

XLDnaute Junior
Bonsoir job75, Chris401, Jocelyn,
merci de toutes vos propositions c est vraiment génial
un grand merci a tous
 

job75

XLDnaute Barbatruc
Bonjour phil77, le forum,

Une formule matricielle est par contre indispensable si l'on veut éviter les valeurs d'erreur :
Code:
=SOMME(SIERREUR(--STXT(A2:C2;TROUVE("=";A2:C2)+1;9^9);))
Fichier joint.

A+
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas