Microsoft 365 Adapter formule condition

Moreno076

XLDnaute Impliqué
Bonsoir le forum

J'aimerais adapter si la colonne A2 est vide mais que L2 ou M2 remplie ou les deux alors N2=" à la formule suivante

=SI(OU(M2="";M2<AUJOURDHUI());"pas de date précise";SERIE.JOUR.OUVRE.INTL(M2;1;11;X$2:X$12))

Merci pour votre aide.
 

Nairolf

XLDnaute Accro
Salut Moreno076, salut sylvanu,

J'arrive un peu après, avec un code similaire :
Code:
=SI(ET(ESTVIDE(A2);OU(NON(ESTVIDE(L2));NON(ESTVIDE(M2))));SI(OU(M2="";M2<AUJOURDHUI());"pas de date précise";SERIE.JOUR.OUVRE.INTL(M2;1;11;X$2:X$12));"")
 

Moreno076

XLDnaute Impliqué
Bonjour Sylvanu, Bonjour Nairolf,

Ca ne fonctionne pas Nairolf.

Sylvanu je ne vois pas

J'ai essayé

=SI(ET(A2="";OU(L2<>"";M2<>""));OU(M2="";M2<AUJOURDHUI());"pas de date précise";SERIE.JOUR.OUVRE.INTL(M2;1;11;X$2:X$12);"")
 

Pièces jointes

  • test.xlsx
    11.5 KB · Affichages: 2

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour le fil,
Essayez ça en N2 :
VB:
=SI(ET(A2="";OU(L2<>"";M2<>""));SI(OU(M2="";M2<AUJOURDHUI());"pas de date précise";WORKDAY.INTL(M2;1;11;X$2:X$12));"")
Il est conforme à vos spécifications :
Code:
La formule actuelle est calculée si :
1- A2 est vide
2- L2 ou M2 est non vide
Sans préjuger de la formule actuelle insérée en N2.
( de toute façon WORKDAY.INTL n'est pas accepté par mon vieux XL2007)
 

Moreno076

XLDnaute Impliqué
Celle la fonctionne =SI(ET(A2="";NBVAL(L2:M2)>0);"";SI(OU(M2="";M2<AUJOURDHUI());"pas de date précise";SERIE.JOUR.OUVRE.INTL(M2;1;11;X$2:X$12)))

Celle ci
=SI(ET(A2="";OU(L2<>"";M2<>""));SI(OU(M2="";M2<AUJOURDHUI());"pas de date précise";WORKDAY.INTL(M2;1;11;X$2:X$12));"")
a l 'effet contraire ca laisse juste "pas de precise" pour les doublons et efface le reste
 

Statistiques des forums

Discussions
292 747
Messages
1 925 837
Membres
182 847
dernier inscrit
belouadah83