Microsoft 365 Adapter formule condition

Moreno076

XLDnaute Impliqué
Bonsoir le forum

J'aimerais adapter si la colonne A2 est vide mais que L2 ou M2 remplie ou les deux alors N2=" à la formule suivante

=SI(OU(M2="";M2<AUJOURDHUI());"pas de date précise";SERIE.JOUR.OUVRE.INTL(M2;1;11;X$2:X$12))

Merci pour votre aide.
 

Nairolf

XLDnaute Impliqué
Salut Moreno076, salut sylvanu,

J'arrive un peu après, avec un code similaire :
Code:
=SI(ET(ESTVIDE(A2);OU(NON(ESTVIDE(L2));NON(ESTVIDE(M2))));SI(OU(M2="";M2<AUJOURDHUI());"pas de date précise";SERIE.JOUR.OUVRE.INTL(M2;1;11;X$2:X$12));"")
 

Moreno076

XLDnaute Impliqué
Bonjour Sylvanu, Bonjour Nairolf,

Ca ne fonctionne pas Nairolf.

Sylvanu je ne vois pas

J'ai essayé

=SI(ET(A2="";OU(L2<>"";M2<>""));OU(M2="";M2<AUJOURDHUI());"pas de date précise";SERIE.JOUR.OUVRE.INTL(M2;1;11;X$2:X$12);"")
 

Fichiers joints

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour le fil,
Essayez ça en N2 :
VB:
=SI(ET(A2="";OU(L2<>"";M2<>""));SI(OU(M2="";M2<AUJOURDHUI());"pas de date précise";WORKDAY.INTL(M2;1;11;X$2:X$12));"")
Il est conforme à vos spécifications :
Code:
La formule actuelle est calculée si :
1- A2 est vide
2- L2 ou M2 est non vide
Sans préjuger de la formule actuelle insérée en N2.
( de toute façon WORKDAY.INTL n'est pas accepté par mon vieux XL2007)
 

Moreno076

XLDnaute Impliqué
Celle la fonctionne =SI(ET(A2="";NBVAL(L2:M2)>0);"";SI(OU(M2="";M2<AUJOURDHUI());"pas de date précise";SERIE.JOUR.OUVRE.INTL(M2;1;11;X$2:X$12)))

Celle ci
=SI(ET(A2="";OU(L2<>"";M2<>""));SI(OU(M2="";M2<AUJOURDHUI());"pas de date précise";WORKDAY.INTL(M2;1;11;X$2:X$12));"")
a l 'effet contraire ca laisse juste "pas de precise" pour les doublons et efface le reste
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Je ne comprends pas.
Par rapport à vos hypothèses du post #1 c'est ma formule qui marche.
Voir en PJ.
Je rappelle :
J'aimerais adapter si la colonne A2 est vide mais que L2 ou M2 remplie ou les deux alors N2=" à la formule suivante
Donc N2 VRAI si et seulement si A2 vide et M2 ou L2 non vide.
 

Fichiers joints

sylvanu

XLDnaute Barbatruc
Supporter XLD
Hi Hi Hi ! :)
Dans votre formule c'est : Si A est vide alors on met Vide, donc le contraire de l'hypothèse de départ.
Donc il suffisait d'inverser :
VB:
=SI(ET(A2="";OU(L2<>"";M2<>""));"";Formule)
;)
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas