4 si imriques pour calculer un solde

GADENSEB

XLDnaute Impliqué
Salut le Forum,
Je galére avec des si Imbriqués

Pour le taf, je dois réalisé une formule qui calcule un solde en u3

Code:
Critères :
- Si M3 (date) est supérieur à datejour (Q1) alors U3=0
- Si M3 (date) est inférieur ou égale à datejour (Q1) alors U3=$O3-SOMME($Y3:$AJE3)-$AL3
- Si la colonne "W3" =0 alors alors U3=0
- Si la colonne "W3" >0 alors alors U3= W3-SOMME($Y3:$AJE3)-$AL3

Pour l'instant j'en suis là et je galère ....

Colone U :
Code:
=SI($M3>$Q$1;$O3;SI($W3=0;$O3-SOMME($Y3:$AJE3)-$AL3;($ER3-SOMME($Y3:$AJE3)-$AL3)))
qqn aurais une idée ?

Merci

bonne aprem

Seb
 

Fichiers joints

st007

XLDnaute Accro
Re : 4 si imriques pour calculer un solde

Bonjour,
=SI($M3>$Q$1;$O3

déjà çà ne respecte pas - Si M3 (date) est supérieur à datejour (Q1) alors U3=0

=SI(M3>Q1;0;valeur si faux ...)
 

GADENSEB

XLDnaute Impliqué
Re : 4 si imriques pour calculer un solde

Je sais je sais
Je galére et je n'arrive pas à inclure les 4 conditions ......
 

Dugenou

XLDnaute Barbatruc
Re : 4 si imriques pour calculer un solde

Bonjour,
Dans quel ordre faut-il traiter les conditions ? (ou quelle est la priorité entre M3 et W3 ?
que faire si M3 >= date du jour et W3 = 0 ? : u3 = 0 ou U3 = $O3-SOMME($Y3:$AJE3)-$AL3
que faire si m3>= date du jour et w3>0 ? : U3=$O3-SOMME($Y3:$AJE3)-$AL3 ou U3= W3-SOMME($Y3:$AJE3)-$AL3
selon vos réponse il sera facile de mettre en ordre les conditions
 

vgendron

XLDnaute Barbatruc
Re : 4 si imriques pour calculer un solde

Hello

je pense qu'il y a un souci dans tes 4 conditions
pour modifier le contenu de U, tu fais un test sur la colonne M et un autre test qui semble totalement indépendant sur la colonne W..
y a t il un lien entre?

Code:
Critères :
1 - Si M3 (date) est supérieur à datejour (Q1) alors U3=0
2 - Si M3 (date) est inférieur ou égale à datejour (Q1) alors U3=$O3-SOMME($Y3:$AJE3)-$AL3
3 - Si la colonne "W3" =0 alors alors U3=0
4 - Si la colonne "W3" >0 alors alors U3= W3-SOMME($Y3:$AJE3)-$AL3
pour mettre U3 à 0, tu as deux conditions: la 1 OU la 3
peut on rassembler les deux?
pour avoir: U3=0 si (M3>Q1) OU (W3=0)

maintenant les conditions 2 et 4
si M3<=Q1 et W3>0.. U3 prend quoi? la fonction avec o3 (condition 2) ou la fonction avec W3 (condition4) ?


Hello Dugenou and St007 ;-)
 

st007

XLDnaute Accro
Re : 4 si imriques pour calculer un solde

Re,
un essai
Code:
=SI(OU($M3>$Q$1;W3=0);0;SI(M3<=$Q$1;O3-SOMME(Y3:AJE3)-AL3;SI($W3>0;W3-SOMME($Y3:$AJE3)-$AL3)))
edit : Bonjour tout le monde, et bon courage, je sens que les conditions vont évoluer ....
 
Dernière édition:

st007

XLDnaute Accro
Re : 4 si imriques pour calculer un solde

Re,
Si j'essaie de comprendre ta feuille,je dirais
que si M3>Q1, tu veux mettre 0, je mettrai comme solde O3+W3
maintenant si M3<Q1
le solde reste (O3+W3)-somme(Y3:AJ3)

ou je m'égare ... ?
 

GADENSEB

XLDnaute Impliqué
Re : 4 si imriques pour calculer un solde

Bonjour à tous
et merci à vous dans un premier temps.

Du coup, je redécris mon schéma dans un ordre plus chrono:

- Déjà il faut que U soit >0 sinon ""
- Si W3>0 et M3<Q1 et alors U3=$w3-SOMME($Y3:$AJE3)-$AL3.
- Si W3=0 ou "" et M3<Q1 et alors U3=$O3-SOMME($Y3:$AJE3)-$AL3.
- Si W3=0 ou "" et M3>Q1 =0


Comme cela doit être correct
pfiouuu
Merci

@ st007 pour le poste 6 ->marche pas sniff



Bonne journée

Seb
 

Dugenou

XLDnaute Barbatruc
Re : 4 si imriques pour calculer un solde

Bonjour,
Merci pour cette ré écriture mais il y a encore quelques ennuis :
- Déjà il faut que U soit >0 sinon "" : à mon avis c'est plutôt à la fin étant donné qu'on calcule U justement
- Si W3>0 et M3<Q1 et alors U3=$w3-SOMME($Y3:$AJE3)-$AL3. Que fait-on quand W3>0 et m3>ou= Q1 ??
- Si W3=0 ou "" et M3<Q1 et alors U3=$O3-SOMME($Y3:$AJE3)-$AL3.
- Si W3=0 ou "" et M3>Q1 =0 Que fait-on quand W3<0 ??
et pour un traitement complet : que faire quand M3=Q1

Pour l'instant ça donnerait :
Code:
=SI(W3>0;SI(M3<Q1;W3-SOMME(Y3:AJ3)-AL3;"??");SI(W3=0;SI(M3<Q1;O3-SOMME(Y3:AJ3)-AL3;0);"??"))
en ajoutant le fait que tu veux "" au lieu de 0 alors :
Code:
=si(SI(W3>0;SI(M3<Q1;W3-SOMME(Y3:AJ3)-AL3;"??");SI(W3=0;SI(M3<Q1;O3-SOMME(Y3:AJ3)-AL3;0);"??"))=0;"";SI(W3>0;SI(M3<Q1;W3-SOMME(Y3:AJ3)-AL3;"??");SI(W3=0;SI(M3<Q1;O3-SOMME(Y3:AJ3)-AL3;0);"??")))
Cordialement
 
Dernière édition:

GADENSEB

XLDnaute Impliqué
Re : 4 si imriques pour calculer un solde

HELLO

- Si W3>0 et M3<Q1 et alors U3=$w3-SOMME($Y3:$AJE3)-$AL3. Que fait-on quand W3>0 et m3>ou= Q1 ??
logiquement ce n'est pas possible.


- Si W3=0 ou "" et M3>Q1 =0 Que fait-on quand W3<0 ??
logiquement ce n'est pas possible car c'est un historique



je regarde tes formules après manger !

Merki

Seb
 
Dernière édition:

Haut Bas