20 fonctions dans une formule ?

ochju

XLDnaute Nouveau
Bonjour à tous,

Voilà j'ai un petit problème sur excel, je veux imbriquer 20 fonctions dans une seule formule , je sais que c'est 7 maximum :(

Ya t-il une solution ?

Voici ma formule pour les plus courageux ==>

=SI(C2=$N$5;B2*$P$5;SI(C2=$N$6;B2*$P$6;SI(C2=$N$7;B2*$P$7;SI(C2=$N$8;B2*$P$8;SI(C2=$N$8;B2*$P$8;SI(C2=$N$9;B2*$P$9;SI(C2=$N$10;B2*$P$10;SI(C2=$N$11;B2*$P$11;SI(C2=$N$12;B2*$P$12;SI(C2=$N$13;B2*$P$13;SI(C2=$N$14;B2*$P$14;SI(C2=$N$15;B2*$P$15;SI(C2=$N$16;B2*$P$15;SI(C2=$N$17;B2*$P$17;SI(C2=$N$18;B2*$P$18;SI(C2=$N$19;B2*$P$19;SI(C2=$N$20;B2*$P$20;SI(C2=$N$21;B2*$P$21;SI(C2=$N$22;B2*$P$22;SI(C2=$N$23;B2*$P$23;SI(C2=$N$24;B2*$P$24;"No")))))))))))))))))))))


avec VBA, est ce possible ?


Merci davance pour vos réponses :)

Thomas.
 

Tibo

XLDnaute Barbatruc
Re : 20 fonctions dans une formule ?

Bonjour ochju et bienvenue,

Tu as la possibilité de nommer des parties de formules qui tiennent compte des 7 niveaux d'imbrication.

Tu peux ensuite réutiliser ces noms dans un nouveau SI

sinon, l'idéal serait de nous expliquer à quoi doit servir ce test en nous joignant le cas échéant un bout de fichier sans donnés confidentielles.

@+
 

chris

XLDnaute Barbatruc
Re : 20 fonctions dans une formule ?

Bonjour
Non.
La fonction SI n'est sans doute pas adaptée à ton cas. Il y a des tas d'autres fonctions qui t'éviteront ces 20 imbrications.
Donne un plus plus d'explications ou un petit fichier exemple pour qu'on te remette sur la bonne piste.
 

ochju

XLDnaute Nouveau
Re : 20 fonctions dans une formule ?

Alors je vous joint un tableau excel pour davantage de compréhension.

En fait je cherche à dire :

Si C2 est egal a une des valeurs dans la colone position (de 1 à 20) alors on multiplie le coefficient correspondant avec B2, Sinon on affiche "No".

il doit surement y avoir une formule plus simple, mais je ne m'y connais pas assez.

Je précise le tableau original fais plus de 2000 lignes.

Merci encore de votre aide

Thomas
 

Fichiers joints

Tibo

XLDnaute Barbatruc
Re : 20 fonctions dans une formule ?

re,

Tu peux essayer avec cette formule en D2 (ou ailleurs) :

=SI(NB.SI($E$2:$E$21;C2)=0;"No";B2*INDEX($G$2:$G$21;EQUIV(C2;$E$2:$E$21;0)))

Regarde et dis nous

@+
 

ochju

XLDnaute Nouveau
Re : 20 fonctions dans une formule ?

Cela fonctionne

Merci de ton aide Tibo.

Au plaisir de pouvoir aider à mon tour une autre personne,

Bonne journée à toi.

Thomas
 

ochju

XLDnaute Nouveau
Re : 20 fonctions dans une formule ?

Tibo ou aun autre, je vais peut être encore abusé de vous :

Voir le fichier joint.


Je souhaite faire la différence entre C2 et A2.
Le problème est que parfois en C2, il y à écris "No".
Ce n'est pas un Chiffre donc excel affiche #VALEUR!

Merci encore

Thomas
 

Fichiers joints

ochju

XLDnaute Nouveau
Re : 20 fonctions dans une formule ?

Je m'en suis sorti.

Merci à vous quand même

A bientot

Thomas
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas