2 Condition

plouff

XLDnaute Junior
Bonjour.
Voila que je bug sur la création d'un code avec 2 condition. Un calvaire vue le temps passé.. :(
voici les de code que j'utilise pour connaitre chaque infos:

=NB.SI(Feuil2!AA2:AA350;Couleur(A13))
Je lui demande combien de cellule dans la feuil2 comporte cette couleurs.

=NB.SI(Feuil2!I2:I350;"* ELECTRICITE (Prélèvement)*")
Je lui demande combien de cellule dans la feuil2 comporte les terme ELECTRICITE (Prélèvement)
Jusque la tout va bien.;)

Maintenant je souhaiterais qu'il me dise combien de cellule comporte la couleur de la cellule A13 avec les termes ELECTRICITE (Prélèvement) dedans.
Sachant qu'il peut y avoir d'autre terme avec la couleur A13.

J'ai essayé plein de chose mais pas moyen de mettre la main sur le bon code.
Exemple:

=NB.SI(Couleur(A13);SI(Feuil2!I2:I350;"* ELECTRICITE*"))
ou
=NB.SI(Feuil2!AA2:AA350;Couleur(A13)&SI(Feuil2!I2:I350;"*ELECTRICITE*"))

J'ai testé avec la fonction ET mais sans résultat.

Ne trouvant pas de solution en retournant le code dans tout les sens, je fais appel a vos lumière pour m'aider dans mon problème qui pour le peux est probablement ridicule..:rolleyes:

Merci d'avance

Je vous souhaite une bonne fin de dimanche.:)
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

As-tu essayé "NB.SI.ENS()"

Sinon un bout de fichier aiderait à te trouver la solution.

JHA
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Avec NB.SI.ENS
Code:
=NB.SI.ENS(Feuil2!$AA$2:$AA$350;Couleur($A13);Feuil2!$I$2:$I$350;"*ELECTRICITE (Prelevement)*")
Edit: Fichier complété

JHA
 

Fichiers joints

Dernière édition:

JHA

XLDnaute Barbatruc
Bonjour à tous,

Il y a aussi sommeprod
Code:
=SOMMEPROD((Feuil2!$AA$2:$AA$350=Couleur($A13))*(Feuil2!$I$2:$I$350="OFFRE DUAL (Prelevement)"))
JHA
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas