Microsoft 365 1er jour du mois reporter chaque fois, ET considérer cases vides

2Excel-user

XLDnaute Nouveau
Bonjour à tous,
et ceux aimant les formules excel et Excel-downloads

Il me manque un peu bcp les automatismes dans ce tableau.

J'explique un peu :
J'ai mis dans Office365 un tableau indiquant les jours du mois dans colonne B:B.

Cela dépend de combien de jours sont à la dernière semaine de fin du mois,
que produit des cellules vides, quand il y a jour de fin du mois ou du weekend, et des erreurs sont affichés
p.ex. la 17e semaine
1re ligne = lundi
2e ligne = mardi
etc.
donne

B4 = lundi le 27 avril 2020
B5 = mardi
B6 = mercredi
B7 = jeudi 30 avril 2020
B8 doit rester VIDE
comme vendredi 01/05 est le mois suivant
et viendra alors dans la 18e semaine sous ...
sous B15
car chaque semaine est mis au tableau de lundi, mardi, mercredi, jeudi, vendredi,

plus de détail, voir le fichier Excel

merci,

Gérard, 2Excel-User
 
Dernière édition:

2Excel-user

XLDnaute Nouveau
Bonjour, j'ai trouvé une des deux problématiques, celle avec les heures dans N.N.

Comme la problématique étrange était de :
p.ex. L11 = 115:00 heures et M11= 105:00 heures
par contre je reçois le message d'erreur que L11 serait < M11 :oops:
je n'avance plus,

J'utilise maintenant 2 différentes cells pour qu'il n'y a plus d'erreurs avec des heures en négatifs .
Le calendrier à cocher 1904, je ne veux pas prendre.

d'abord p.ex. O11=L11-M11
et puis p.ex. N11 = =SI(O11<0;"-"&TEXTE(ABS(O11);"[h]:mm");O11) :)


restant à résoudre encore avec Fin du Mois et si case vide plus considérer la ligne correcte de jour :oops:

temps pour aller sur une terrasse, ouverte depuis peu
 
Dernière édition:

2Excel-user

XLDnaute Nouveau
Bonjour à tous, et aussi au suivi du fil.

colonne N:N fonctionne
MAIS Colonne B:B ne sait pas comment résoudre,
de reporter date début du mois à la prochaine semaine

Cela dépend de combien de jours sont à la dernière semaine de fin du mois,
que produit des cellules vides, quand il y a jour de fin du mois ou du weekend, et des erreurs sont affichés
p.ex. la 17e semaine
1re ligne = lundi
2e ligne = mardi
etc.
donne

B4 = lundi le 27 avril 2020
B5 = mardi
B6 = mercredi
B7 = jeudi 30 avril 2020
B8 doit rester VIDE
comme vendredi 01/05 est le mois suivant
et viendra alors dans la 18e semaine sous ...
sous B15
car chaque semaine est mis au tableau de lundi, mardi, mercredi, jeudi, vendredi,

merci,.
 

Fichiers joints

Dernière édition:

2Excel-user

XLDnaute Nouveau
Bonjour à tous,
je n'ai pas encore pu trouver de fonctions et des conditions que le 1er du mois va dans prochaine semaine. J'ai cherché dans d'autres fils et discussions sous excel-downnloads, mais
Chaque semaine a 5 jours dans ce tableau de lu-ve.
Lorsque le dernier jour (30/04) de la 18e semaine est jeudi, alors le vendredi 01er mail est affiché en 19e semaine.
Comment faire si Ve = 29/05, ...
merci pour d'astuce,
Gérard, 2Excel-User
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas