1 formule SI= que je n'arrive pas à faire fonctionner

jensaisrien

XLDnaute Nouveau
Bonjour,

Voilà:
dans B12 j'ai une cellule lié une case à cocher.
dans C10 c'est une case à quantité. ex: 5

J'aurai voulu dans C34 pouvoir faire un résultat si B12 coché alors on aura 5*1.26€ = 6.30€


J'ai tapé ceci : =SI(B12=VRAI;"[(1,26*C10)]";"")


Mais voilà ça ne calcule pas ça écrit 1,26*C10.

Comment dois-je faire pour prendre en compte en fait la formule et non du texte?

Merci par avance
 

TempusFugit

XLDnaute Impliqué
Re : 1 formule SI= que je n'arrive pas à faire fonctionner

Bonjour

Et comme ca ?
=SI(B12=VRAI;1,26*C10;"")

Tu peux aussi te passer du SI en utilisant la formule suivante:
=(B12=VRAI)*1,26*C10
 
Dernière édition:

jensaisrien

XLDnaute Nouveau
Re : 1 formule SI= que je n'arrive pas à faire fonctionner

bonjour à vous,

Merci beaucoup, Ca a marché comme ceci ( n° case j'ai changer en ayant ajouté et supprimé des lignes)
=SI(B18=VRAI;C15*B19;"0")

Sauf que maintenant on me demande des boutons radios et non plus des cases à cocher. Je vais chercher car ca devrait être assez similaire.

Merci bcp,
 

jensaisrien

XLDnaute Nouveau
Re : 1 formule SI= que je n'arrive pas à faire fonctionner

re,

J'ai fini par trouver.

Voici ce que j'ai si un jour ça doit aider quelqu'un


Mon problème était d'avoir au choix 6 menus. Ne pas pouvoir en choisir plus d'un.
Les menus ont tous le meme prix mais on pourrait avoir d'autres prix.

E16 est relié à tous boutons radios. Si le premier bouton radio est coché, la case E16 contiendra 1. Si le deuxième bouton radio est coché alors la case E16 contiendra le chiffre 2.

Ensuite dans mes totaux, j'ai simplement mis si E16= 1 alors on doit avoir la cellule C14 qui se multiplie avec la E17. Dans C14 j'ai la quantité de personne et dans E17 le prix. On fait la même chose de E16= 1 à E16=6 et voilà.

=SI(E16=1;C14*E17;"0,00€")+SI(E16=2;C14*E21;"0,00€")+SI(E16=3;C14*E25;"0,00€")+SI(E16=4;C14*E29;"0,00€")+SI(E16=5;C14*E33;"0,00€")+SI(E16=6;C14*E37;"0,00€")

Merci bcp,
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas