Résultats de la recherche

  1. E

    XL 2019 duplication onglet

    Ben essaie et reviens avec une question précise si tu as un pb ;-)
  2. E

    XL 2019 duplication onglet

    Re, choisir non, mais tu peux supprimer ceux non voulus : ActiveSheet.Shapes.Range(Array("CommandButton1")).Delete eric
  3. E

    XL 2010 EXTRAIRE TOUS LES PAIEMENTS PAR CHEQUE DE MON TABLEAU

    Bonjour, la macro fournie sur l'autre fil n'allait pas ? eric
  4. E

    XL 2019 duplication onglet

    Bonjour, Crée une feuille modèle vierge. Et copie la feuille et non ses cellules. Sub copieModele() Sheets("Modèle").Copy After:=Sheets(Sheets.Count) ActiveSheet.Name = InputBox("Nom de la feuille", "Nommer") End Sub eric
  5. E

    XL 2010 EXTRAIRE TOUS LES PAIEMENTS PAR CHEQUE DE MON TABLEAU

    Bonjour, pourquoi avoir fait un doublon ? https://www.excel-downloads.com/threads/extraire-toutes-les-ventes-par-cheque-uniquement.20039050/ eric
  6. E

    XL 2010 Extraire toutes les ventes par chèque uniquement

    Au fait je n'ai pas mis les dates car celles mises et celles de la régie ne correspondaient pas et je ne savais pas quoi mettre. Tu peux compléter la macro. Ce n'est pas le plus difficile mais si tu ne connais pas tu peux demander. eric
  7. E

    XL 2010 Extraire toutes les ventes par chèque uniquement

    Bonjour, une macro qui se lance quand tu quittes la feuille REGIE 2020. J'ai prévu 25 lignes, avec une alerte si on dépasse. Tu peux choisir d'arrêter pour adapter ta feuille ou continuer. Réglable avec la constante nbCheq mise au début du code. J'utilise les codenames des feuilles. Tu peux les...
  8. E

    XL 2010 Extraire toutes les ventes par chèque uniquement

    Bonjour à tous, si tu dois absolument respecter le format du bordereau, ça sera sans doute plus simple avec une macro. Mais y-a-t'il un nombre de lignes maxi ? 10 sur ton exemple... eric
  9. E

    Office 365 Message d'erreur

    Bonjour à tous, =SI(et(D24<>"";c24<>"" ); le reste de ta formule ;"") ou bien : =SI(ou(D24="";c24="" );"";"ta_formule) ou =sierreur(ta_formule;"") eric
  10. E

    XL 2016 numéro semaine

    Tu te mélanges entre Modeste et moi... Mais pourquoi veux-tu ton propre système de numérotation des semaines qui aura forcément des failles (je sens arriver des semaines à plus de 7j et d'autres à moins de 7j), plutôt que d'utiliser le système ISO ? Le seul reconnu en europe, et celui que tu...
  11. E

    XL 2016 numéro semaine

    Je te demande pour 5 dates, tu en fournis 3 dont 1 non demandée, et sans préciser l'année... Et bien mettre ce que tu veux avoir, pas ce que tu as. Si tu as vraiment 3 semaines différentes pour 3 jours consécutifs ça n'a pas grand sens.
  12. E

    XL 2016 numéro semaine

    Bonjour, Ah mais c'est là-dessus que je suis parti moi sebastaupole, tu veux dire que la semaine 1 n'existe pas ? Jamais ? Je trouve cela particulièrement étrange. Que dois-tu avoir pour le 31/12/18, le 01/01/19, le 07/01/19,puis le 31/12/19 et le 01/01/20 ? eric
  13. E

    XL 2016 numéro semaine

    Re Staple, à mon avis on ne peut pas faire numsem=numsem +/-1, ça serait trop simple. Il faut le recalculer pour la date décalée. Sinon je pense que ton stock est la meilleure solution :) (sur date décalée de +7, +14, etc bien sûr). Je n'ai pas trouvé d'erreur sur une longue durée (au moins 100...
  14. E

    XL 2016 numéro semaine

    Bonjour à tous, 52+1 fera toujours 53... Calcule plutôt le n° de semaine de date+x : NumSem = DatePart("ww", Date + 7 , vbMonday, vbFirstFourDays) à noter que Datepart est un peu bogué et donne des mauvais n° de semaine sur certaines dates dont, pas de pot, une cette année Erroné sur dates ...
  15. E

    XL 2010 VBA Tester Cells.find

    Bonjour à tous, pourtant tu es sur la bonne piste if marecherche is nothing then ' non trouvé else ' trouvé endif eric
  16. E

    Autres Trouver deux fractions dont la somme vaut une fraction

    Et bien ton expert aurait dû rédiger un cahier des charges clair et complet, il aurait été suivi. Là il faudrait qu'il s'explique. Si ces 2 points sont identiques, pour moi c'est différent s'il est obtenu soit en avançant de 3/4 de tour, soit en avançant d'un tour puis en reculant d'1/4 de...
  17. E

    Autres Trouver deux fractions dont la somme vaut une fraction

    Démesurée, je ne sais pas, mais faute d'un autre algorithme il n'y a pas le choix. Surtout que c'est assez rapide donc pas de raison de se prendre la tête. Je peux t'afficher des solutions plus mauvaises si tu veux, ça je sais faire :) Plaisanterie mise à part, on pourrait ajouter une colonne...
  18. E

    Autres Trouver deux fractions dont la somme vaut une fraction

    Bonjour, je pense que tu peux vu que j'explore toutes les combinaisons des plateaux pris 2 à 2, et toutes les possibilités de trous pour chaque plateau, pour ne retenir que la somme des quotients la plus proche de la fraction initiale. Difficile de passer à coté s'il n'y a aucun trou dans la...
  19. E

    Soustraire des horaires sur 2 jours différents

    Bonjour, Quel problème ? Ces proposition sont faites justement pour traiter ce type de besoin. eric
  20. E

    Autres comment utiliser lecteur rfid usb dans xls

    Bonjour, Bien trouvé Staple, je ne connaissais pas. J'adore cette phrase de MS dans l'information additionnelle : :) eric
Haut Bas