Résultats de la recherche

  1. bqtr

    Zone de liste dans une barre de menu excel 2007

    Bonjour à tous, Je viens de passer sous Excel 2007 et j'ai déjà des problèmes :(. Sur mon fichier fait avec Excel 2003 tout est nickel mais avec Excel 2007 je n'arrive pas à récuper la zone de liste de ma barre de menu. La nouvelle barre se place bien dans l'onglet "Complément", les deux...
  2. bqtr

    référence cellule

    Bonjour à tous, J'essaye de répondre à quelqu'un mais j'ai du mal avec le système de référence R1C1. A quoi correspond la cellule C[-7] dans cette exemple : Range("H15").Select ActiveCell.FormulaR1C1 = _ "=VLOOKUP(C[-7],'ventes flegs journaliere.csv'!R1C1:R50000C5,4,FALSE)"...
  3. bqtr

    Moyene en excluant les cellules vides et avec 0 comme valeur

    Bonjour le forum, Sur une ligne de douze cellules ( 1 par mois ), avec comme valeur des pourcentages, je souhaite dans la trezième en faire la moyene. J'utilise ceci qui fonctionne bien sauf si une ou plusieurs des cellules ont comme valeur 0% (zéro) : =SOMME(G5:R5)/NBVAL(G5:R5)...
  4. bqtr

    Tableau variable à 1 seul élément

    Bonsoir tout le monde, Je me heurte à un problème pour répondre à un fil de LocSta. Dans le fichier joint, j'affiche une liste de fichier en A5:A.... cette liste je la mets en mémoire dans un tableau (tablosave). Ensuite si on coche le checkbox "Afficher uniquement le nom du fichier", les...
  5. bqtr

    Copier/Coller

    Bonsoir tout le monde, Guylaine Suite au problème de dimanche, j'ouvre ce fil qui est la suite d'un autre que Guylaine avait ouvert. Dans ce fichier, la création des formules des feuilles "quadrimestre" et "recap annuelle" se fait instantanément Bonne soirée P.O
  6. bqtr

    Recherche répertoire

    Bonsoir tout le monde, En recherchant sur le forum, j'ai trouvé cette macro de Pascal76 pour choisir un répertoire. Dim objShell As Object, objFolder As Object Dim SecuriteSlash As Integer Set objShell = CreateObject("Shell.Application") 'recuperer nom repertoire cible Set objFolder =...
  7. bqtr

    Explication sur 9^9 dans les formules

    Bonjour tous le monde, Plusieurs fois dans des posts, 9^9 est mis dans dans formules diverses Comme hier par André : Pour le minimum : En B1 : =SI(A1<B1;A1;B1) Il faut démarrer en tapant 9^9 en A1 pour trouver le minimum que la cellule A1 a pris aprés avoir été modifiée plusieurs fois Ou...
  8. bqtr

    Test sur une date

    Bonjour le forum, J'ai un TextBox1 alimenté par un contôle calendar1, et il affiche une date sous la forme dddd dd-mm-yyyy. Je souhaite réaliser un test sur cette date avec un bouton de commande. J'ai rentré cette formule, mais elle ne fonctionne pas : Private Sub Mat_C_Click() If...
  9. bqtr

    Inserer une progressbar dans un USF

    Bonjour le forum J'ai la macro suivante qui fonctionne bien Sub Macro1() Dim Feuille as Worksheet For each Feuille in Sheets(Array( "Feuilb", ........,"Feuilg")) Feuille.Activate With ActiveSheet.PageSetup .Zoom = 80 End With Next Sheet("FeuilA").select End...
Haut Bas