Résultats de la recherche

  1. T

    Trop ou pas assez de parenthèse

    Bonjour Chantal. Essaye ainsi : =SI(SOMME('[METRE PROJET 001.xls]PLAQUISTE'!$D$38:$D$40)>0;"X";"SO") Dans ta formule original tu as un OU de trop.
  2. T

    Adapter une formule matriciel en macro

    Ca pourrait être réalisé avec l'évènement. Mais pour tout ça il faudrait avoir un fichier qui sera figé dans la liste des horaires, des types d'absences, des collaborateurs.
  3. T

    Adapter une formule matriciel en macro

    C'est tout à fait possible mais il n'y aura aucun recalcule. Donc si tu ajoutes des dates ou en modifie tu dois relancer manuellement.
  4. T

    Soustraire des horaires sur 2 jours différents

    "24:00:00" correspond juste à minuit, c'est une façon de faire plus lisible pour moi ;) Bonne journée le fil.
  5. T

    Exclusion de valeur selon condition dans une combobox en cascade

    Bonjour Galaktus. '***' Intervenir ici. '***' Boucler les valeurs de la liste selon la couleur. 'Boucle de chaque élément de la zone. For Each k In Sheets("Inventaire montages").Range(NomRange) 'Si la police d'écriture est 255 (rouge) alors. If Not k.Font.Color = 255...
  6. T

    XL 2016 If TextBox contient uniquement du texte

    Merci pour l'information, je ne savais pas :)
  7. T

    XL 2016 If TextBox contient uniquement du texte

    Bonjour Bruno. Si nous avons Trigramme = "TE0" Val nous donnera bien 0 non ?
  8. T

    XL 2016 If TextBox contient uniquement du texte

    Bonjour Victor. En bouclant les différents caractères de ta valeur. 'Trigramme If Trigramme = "" Then MsgBox "Veuillez renseigner le trigramme de l'opérateur dans l'onglet Mouvements de stock" ElseIf Len(Trigramme) <> 3 Then MsgBox "Le trigramme que vous avez rentré fait " &...
  9. T

    Adapter une formule matriciel en macro

    Avec une fonction personnalisée. Le code en détails : Function planning_chich(dJour As Date, rRaisons As Range, rPeriode As Range) As String Dim tRaisons(), tPeriodes() Dim i As Byte, j As Byte 'Enregistre les raisons dans un tableau virtuel. tRaisons = rRaisons.Value 'Enregistre la période...
  10. T

    Adapter une formule matriciel en macro

    Ne pourrait-on pas plutôt créer une fonction personnalisée, où tu indiques les différents champs de recherche ?
  11. T

    XL 2010 VBA | Ecriture prédictive adresse email

    Bonjour Ralph. Je te propose cette solution : Private Sub TextBox1_Change() alimTB3 End Sub Private Sub TextBox2_Change() alimTB3 End Sub Private Sub alimTB3() If Me.TextBox1.Value = "" And Me.TextBox2.Value = "" Then Me.TextBox3.Value = "": Exit Sub If Me.TextBox2.Value <> ""...
  12. T

    Adapter une formule matriciel en macro

    Bonjour chich. Re-bonjour vgendron. En adaptant ton fichier on pourrait trouver une réponse en formule. Je te propose sur une seule période pour le moment, le mieux pour moi serait d'avoir les périodes les unes en dessous des autres.
  13. T

    2 Macro : 1 Suppr. ligne et 1 Suppr. heure

    Il faut bien en fin d'année :)
  14. T

    Imbrication de SI

    =SI(SI(C1="Creux";NBVAL(AJ143:AJ145);NBVAL(AJ146:AJ148)>0);"X";"SO") Il manquait une parenthèse.
  15. T

    Imbrication de SI

    Bonjour Chantal. Bonjour Red. =SI(C1="Creux";SI(NBVAL(AJ143:AJ145)>0;"X";"SO");SI(NBVAL(AJ146:AJ148)>0;"X";"SO")) Ou pour faire plus court : =SI(SI(C1="Creux";NBVAL(AJ143:AJ145);NBVAL(AJ146:AJ148)>0;"X";"SO")
  16. T

    2 Macro : 1 Suppr. ligne et 1 Suppr. heure

    Pour proposer une version avec array, voici un autre code. Les fonctions sont tirées du site de Boisgontier, la seconde est juste adaptée. Private Sub UserForm_Initialize() With Me .cbMod.List = Array("Modification Convoi", "Modification Horaire", "Modification Roulement", "Modification...
  17. T

    Soustraire des horaires sur 2 jours différents

    Bonjour Tuti. Tu peux essayer une formule de ce type : =SI(C4<B4;"24:00:00"-B4+C4;C4-B4) Ta formule n'est pas mauvaise non plus, mais il faut activer le calendrier 1904 dans les options avancées, tu auras un résultat négatif.
  18. T

    XL 2016 Macro pour decompte de kms

    Bonjour Jalucyne : Un exemple : Sub distance_restante() Dim dD%, dJ%, dR% With Sheets("Feuil1") dD = .[A2].Value If .[D2].Value = "" Then dR = dD Else: dR = .[D2].Value End If dJ = .[I2].Value dR = dR - dJ If dR < 0 then dR = 0 .[D2].Value = dR End...
  19. T

    2 Macro : 1 Suppr. ligne et 1 Suppr. heure

    Bonjour Yann. Bonjour vgendron. Voici le code adapté : Option Explicit Private Sub cmdHeures_Click() Dim heure As Date Dim col As Byte Dim comp$ Dim i& With Me If Not IsDate(.tbHeure.Value) Then MsgBox "Inscrire l'horaire selon le format: hh:mm:ss": Exit Sub heure = .tbHeure.Value...
  20. T

    2 Macro : 1 Suppr. ligne et 1 Suppr. heure

    Tu n'as peut-être pas de tableau objet alors, tu peux transmettre une image du fichier ?
Haut Bas