Résultats de la recherche

  1. D

    Résolu Microsoft 365 Problème arrondi et total

    Bonjour à tous, je fais un calcul avec un arrondi et je dois arriver à un total de 100, mais avec certains arrondis j'arrive à 100.02. je sais limiter le résultat à 100, mais ce n'est pas ce que je veux faire. Je voudrais que ça modifie de manière aléatoire ou pas, un chiffre dont je fais la...
  2. D

    Résolu Gestion erreur VBA

    Bonjour à tous, je me demandais comment gérer une erreur sans GoTo, sur un élément spécifique: je transforme des cellules dans une plage, mais il se peut qu'il n'y ait aucune cellule a transformer, du coup j'ai un plantage. J'ai pour le moment mis un GoTo mais s'il y a une autre erreur, ça ne...
  3. D

    Résolu SOMMEPROD somme plusieurs conditions

    Bonjour, Je penses qu'il est possible de simplifier la formule mais je ne trouve pas, je dois additionner la colonne C avec plusieurs conditions dans la colonne B, j'ai utilisé ...
  4. D

    Résolu Addition si existe dans une liste

    Bonjour à tous, Est il possible d'additionner des sommes par rapport au contenu d'une cellule si elle se trouve dans une liste? C'est pas super clair, je sais, aussi je vous mets un fichier en exemple au cas ou. Merci
  5. D

    Résolu XL 2019 CodeName Value

    Bonjour à tous, Je butte sur un petit problème, je me sers des codename pour appeler mes onglet en vba, mais quand j'appelle le fichier, je n'arrive pas à trouver la syntaxe, j'ai un message d'erreur. Workbooks(Nom).Feuil1.Range("C" & CptNoms) = DateNaissanceExtra Je ne peux pas mettre...
  6. D

    Résolu Columns(1) par colonne nommée

    Bonjour à tous, j'utilise .find pour trouver un mot dans une colonne, mais je n'arrive qu'à le faire avec [A:A] ou ActiveSheet.Columns(1) comment lui dire avec le nom de la colonne? Set PlageDeRecherche = ActiveSheet.Columns(1) en Set PlageDeRecherche = nomdemacolonne Merci
  7. D

    XL 2016 Rafraîchissement de page

    Bonjour à tous, J'ai un problème de rafraichissement de page que je ne m'explique pas, il suffit que je clique sur un menu déroulant (ou après exécution d'une macro), pour qu'il y est une superposition d'onglet. Je vous joints un exemple. Auriez vous une idée de comment régler le problème? Moi...
  8. D

    XL 2010 Méthode Select de l'objet "_worksheet" a échoué

    Bonjour à tous, j'ai un petit problème que je n'arrive pas à résoudre quand j’appelle la sélection d'un onglet j'ai un message d'erreur : La Méthode 'select' de l'objet '_worksheet' a echoué Si je mets : Windows(NomFichier).Activate Feuil6.Select ça met le message d'erreur, si je mets...
  9. D

    Alt E G V ne marche plus?

    Bonjour à tous, J'ai du faire une manip sans m'en rendre compte, mais ça fait des années que je me sers des touches pour faire mes copier/coller et je n'arrive plus à faire copier/coller en valeur. Alt E G V me marque v et ne me fais plus le collage en valeur (pareil pour tous les collage...
  10. D

    Doublon Target sur 2 colonnes

    Bonjour à tous, je voudrai détecter des doublons et les bloquer, mais cela se fait sur 2 colonnes et je ne sais faire que sur une seule, je ne sais même pas si c'est possible. Je vous joins un fichier pour voir si vous avez une solution. Dans le fichier, le doublon se fait bloquer sur...
  11. D

    Groupe de cellule offset

    Bonjour, Y a t'il un moyen de faire des groupes de cellules avec offset? à l'heure actuelle j'utilise : Range("deb_notes").Offset(j - 1, 0) = Workbooks(NomFichier).Worksheets(nom_onglet).Range(deb_notes_comp).Offset(i - 1, 0)...
  12. D

    Flèche liste déroulante toujours visible qui ne devrait pas l'être.

    Bonjour à tous, J'ai un petit bug que je n'arrive pas à résoudre, j'ai une petite flèche de menu déroulant qui apparaît en permanence, même si je supprime la validation de donnée "liste". Elle n'est pas tout à fait identique à celle qui apparaît quand je sélectionne la cellule et sa liste est...
  13. D

    Liste avec conditions

    Bonjour à tous, je n'arrive pas à faire une liste dans validation de données avec une condition. Si je mets : =SI($AF3>0;"";PreQual) ou =SI($AF$3=0;PreQual;"") j'ai le message d'erreur La liste source doit être délimitée ou faire référence à une seule ligne ou colonne. Si je mets...
  14. D

    Macro corrompu

    Bonjour à tous, j'ai un classeur excel dont toutes les macros ont été corrompues, impossible de savoir ce qu'il c'est passé exactement (trop d’intermédiaires). Il y a dans le classeur des feuilles nommées avec des accents et dans la macro, tous les accents ont été tronqué ou remplacé par...
  15. D

    Office 32bits, 64bits et VBA7

    Bonjour à tous, J'ai eu un problème technique avec un tableur et j'aimerai comprendre 2 ou 3 choses. J'utilise office 2013 32bits et mon tableur marche parfaitement, quand je vais sur office 2010 64 bits, j'ai des messages d'erreur, que j'ai rectifié en ajoutant une condition if vba7 et...
  16. D

    CheckBox dans Ruban excel

    Bonjour à tous J'ai un problème avec un ruban personnalisé, j'ai mis des cases à cocher checkBox, quand je sélectionne la checkBox la macro se lance bien, mais elle se lance aussi quand je la décoche. 2 choses Comment le décocher une fois dé valider et comment faire pour que la macro ne...
  17. D

    Afficher liste feuilles masquées

    Bonjour à tous, Je voulais savoir s'il était possible d'afficher la liste des feuilles masquées afin de pouvoir choisir de rendre une feuille visible. Comme quand on fait clic droit sur un onglet et afficher la liste apparait et il ne reste plus qu'à choisir la feuille a afficher. Merci.
  18. D

    [règlé]Masquer les feuilles qui contiennent un mot dans leur nom

    Bonjour à tous, Je voulais savoir s'il était possible de faire une macro masquant tous les onglets qui contiennent dans leur nom le mot "libre". Merci
  19. D

    Masquer adresse mail d'envoi

    Bonjour à tous, J'envois des mails automatique et j'aimerai que l'adresse d'envoi soit marqué nepasrépondre, mais quand je mets .From ="nepasrepondre@gmail.com" l'adresse qui apparaît est quand même l'adresse d'envoi, si je fais répondre c'est l'adresse d'envoi qui apparait, une idée...
  20. D

    [règlé]Calcul Manuel et auto Vba

    Bonjour à tous, J'ai un petit problème avec un For Der_lign = Range("B65536").End(xlUp).Row 'Application.Calculation = xlCalculationManual For x = 6 To Der_lign Set PlageDeRecherche = ActiveSheet.Columns(22) Set Trouve...
Haut Bas