Contenu récent par tellib

  1. T

    Sommeprod avec cellule vide

    Re : Sommeprod avec cellule vide Oui ça fonctionne... Merci beaucoup à tous votre aide ! et particulièrement à JCGL dont je vais garder la solution
  2. T

    Sommeprod avec cellule vide

    Re : Sommeprod avec cellule vide Vous avez du mal lire mon mail car ($C$2:$C$5058<>"") figure bien dans mon sommeprod : =SOMMEPROD(($B$2:$B$5058=$F4)*($C$2:$C$5058<>"")*($C$2:$C$5058))
  3. T

    Sommeprod avec cellule vide

    Re : Sommeprod avec cellule vide oui mais là c'est un exemple pour comprendre le fonctionnement de la fonction sommeprod en fait dans mon projet j'ai plusieurs autres critères à rajouter par ailleurs comme indiqué je veux conserver les valeurs 0 dans la moyenne ce sont uniquement les valeurs...
  4. T

    Sommeprod avec cellule vide

    Re : Sommeprod avec cellule vide merci mais je veux garder les valeurs 0 dans la moyenne ce sont les valeurs vides uniquement que je veux éliminer de plus je préférerais utiliser la fonction sommeprod
  5. T

    Sommeprod avec cellule vide

    Re : Sommeprod avec cellule vide c'est à a dire ?
  6. T

    Sommeprod avec cellule vide

    Bonjour à tous, j'ai un problème avec la fonction Sommeprod et les cellules vides. je dois calculer une moyenne de montants par âge mais certains montants sont vides et la fonction sommeprod me retourne #VALEUR! =SOMMEPROD(($B$2:$B$5058=$F4)*($C$2:$C$5058<>"")*($C$2:$C$5058)) ci-joint...
  7. T

    Téléchargement automatique fichier csv d'internet via Excel

    Re : Téléchargement automatique fichier csv d'internet via Excel Merci j'ai réussi cette étape maintenant j'ai un autre problème en fait quand le téléchargement ne peut pas s'effectuer au lieu de la boite de téléchargement j'ai une boite de dialogue de type popup ou msgbox avec un bouton...
  8. T

    Téléchargement automatique fichier csv d'internet via Excel

    Bonjour J'ai réalisé une macro Excel qui télécharge sur un site internet après validation d'un formulaire un fichier Csv. Seulement j'arrive à une boite de dialogue qui s'affiche "Téléchargement de fichier" avec les boutons Ouvrir Enregistrer Annuler Comme j'ai besoin d'un traitement...
  9. T

    SommeProd avec critères variables

    Re : SommeProd avec critères variables merci pour votre aide en fait j'ai plus de 100 000 enregistements une vingtaine de colonnes avec des somme.prod.... et j'ai des temps de recalculs d'une vngtaine de seconde.... donc si je dois tout multplier par 5.... alors on ne sait jamais...
  10. T

    SommeProd avec critères variables

    Re : SommeProd avec critères variables merci pour cette solution mais ca me convient pas trop car ce que j'ai mis est un exemple simple mais mon projet est beaucoup plus compliqué et votre solution équivaut à faire le calcul 5 fois et ensuite rechercher la bonne solution ce que je voudrais...
  11. T

    SommeProd avec critères variables

    Bonjour, j'essaye d'utiliser une seule fonction sommeprod où l'utilisateur choisira son critère de sélection : <, <=, =, >, >= mais je n'y arrive pas : à chaque fois j'ai une erreur de syntaxe aussi je sollicite votre aide je vous joint un fichier Excel en exemple Merci d'avance
  12. T

    Trouver le dernier cours du mois

    Re : Trouver le dernier cours du mois 3 solutions différentes qui fonctionnent ! Merci à tous... Vous être vraiment très forts sur ce forum....
  13. T

    Trouver le dernier cours du mois

    Re : Trouver le dernier cours du mois wouah impressionnant... merci beaucoup ca marche ! je suis bluffé... vous pouvez me donner quelques explications sur ces formules miracles ? j'aimerais comprendre comment vous avez procédé...
  14. T

    Trouver le dernier cours du mois

    Re : Trouver le dernier cours du mois merci... ci joint un autre fichier de comment je voudrais récupérer les résultats
  15. T

    Trouver le dernier cours du mois

    Re : Trouver le dernier cours du mois ca y est j'ai joint le fichier exemple dans mon premier message... pour cause de poids j'en ai mis qu'un extrait...
Haut Bas