Contenu récent par Johan

  1. J

    Transfert de données

    Salut, Essaye ceci, en A4 =SIERREUR(INDEX(Province!B:B;EQUIV('État des résultats'!C4;Province!D:D;0));"") Et en B4 : =SIERREUR(INDEX(Province!C:C;EQUIV('État des résultats'!C4;Province!D:D;0));"") Formule à étirer Johan
  2. J

    XL 2013 VBA COPIER COLLER SOUS CONDITION

    Re, MAJ avec la condition qui vérifie bien niveau ET date de formation sont non-vides : Sub CopierColler() Dim lastLine As Long lastLine = ActiveWorkbook.Sheets("SUIVI DE FORMATION").Range("A3").End(xlUp).Row + 1 ActiveWorkbook.Sheets("SUIVI DE FORMATION").Range("A3:G3" &...
  3. J

    XL 2013 VBA COPIER COLLER SOUS CONDITION

    Le code sans la comparaison Sub CopierColler() Dim lastLine As Long lastLine = ActiveWorkbook.Sheets("SUIVI DE FORMATION").Range("A3").End(xlUp).Row + 1 ActiveWorkbook.Sheets("SUIVI DE FORMATION").Range("A3:G3" & lastLine).ClearContents 'FONDERIE For Each cell_TableauFonderie In...
  4. J

    XL 2013 VBA COPIER COLLER SOUS CONDITION

    Regarde si c'est mieux là. C'est normal les dates vides ? PS : la macro doit être lancée depuis l'onglet usinage
  5. J

    XL 2013 VBA COPIER COLLER SOUS CONDITION

    Salut, A priori juste un décalage de cellules, la structure de ce tableau est différente de l'autre fichier. Toujours d'actualité cette idée de comparer avant de recopier ? Johan
  6. J

    Générer des données entre deux fichiers excel

    Bonjour, C'est tout à fait possible mais comment souhaites-tu procéder ? Est-ce un bouton qui va déclencher le programme et aller chercher toutes les informations sur l'autre fichier ? Va-t-il y avoir plusieurs onglets "recette" dans ton fichier "Recette 1 ex" ou vas-tu plutôt à chaque fois...
  7. J

    XL 2013 VBA COPIER COLLER SOUS CONDITION

    Re, Content pour toi :) C'est facile pour moi quand le besoin est aussi clair et aussi bien expliqué, comme tu l'as fait. Pour ta question oui le code s'adaptera à un autre fichier tant que les 2 onglets que j'ai utilisé gardent exactement le même nom Je sais pas qui aura accès en écriture...
  8. J

    XL 2013 VBA COPIER COLLER SOUS CONDITION

    Re, Un premier essai en PJ Dis moi si ça répond à ton besoin
  9. J

    XL 2010 Différence de date ( Résolu )

    Bonjour, Que se passe-t-il s'il y a à la fois des dates dans la colonne G et K sur la même ligne ? exemple : une entre 18 et 24 et l'autre supérieure à 24.. merci
  10. J

    XL 2013 VBA COPIER COLLER SOUS CONDITION

    Bonjour, oui c'est possible, mais ca va pas être pratique vu que l'information "Opérateur " est répétée sur la ligne 4 et 19 et qu'il va falloir aller la récupérer en fonction du tableau. J'aurais préféré un seul tableau. Autre point qui me paraît un peu "casse-gueule" c'est cette histoire de...
  11. J

    XL 2013 VBA COPIER COLLER SOUS CONDITION

    Salut, Je t'ai fait un début de code, mais j'ai pas le temps de finir, me manque les calculs de date et finir la comparaison entre la boucle précédente Sub CopierColler() Dim lastLine As Long lastLine = ActiveWorkbook.Sheets("Formation").Range("A3").End(xlUp).Row + 1...
  12. J

    XL 2010 Problème sur formule Si avec plusieurs conditions

    Bonjour, Ci-joint la formule dans le fichier
  13. J

    XL 2016 Remplissage auto par formule incluant des lettres

    Hmm, j'ai essayé de mon côté et ça semble marcher Regarde si c'est bon sur le fichier joint => D2 devient vert quand tout est sur "R" et D2 devient orange si une ou plusieurs de valeurs ne sont pas sur "R"
  14. J

    XL 2016 Remplissage auto par formule incluant des lettres

    Salut, A tester en D2, mise en forme conditionnelle : =OU($D$5:$D$17<>"R")
  15. J

    Metre en couleur des cellules contenant un commentaire spécifique

    Salut, Tu te compliques la vie, VBA c'est tout simple ^^ "If c = Commentaire" suffit
Haut Bas