Contenu récent par job75

  1. job75

    XL 2019 VBA TROUVER UN NOMBRE MANQUANT DANS UNE SUITE DONNEE

    C'est une des bonnes raisons d'utiliser le Dictionary.
  2. job75

    XL 2019 Ouvrir le fichier le plus récent d'un dossier dans VBA

    Arrêtez de bricoler les codes qu'on vous donne, ça ira mieux. Car vous n'arrêtez pas : au post #32 vous parliez des trains 19 et 149, maintenant on ne les voit plus !
  3. job75

    XL 2019 VBA TROUVER UN NOMBRE MANQUANT DANS UNE SUITE DONNEE

    Bonjour le forum, Tu sais certainement que ça prend du temps sur un grand tableau, le Dictionary l'évite. A+
  4. job75

    XL 2016 Selection des onglets via combobox sans les afficher

    Private Sub CommandButton1_Click() 'bouton Ajouter Dim DL As Long If ONGLET.ListIndex = -1 Then ONGLET.SetFocus: Exit Sub If TextBox8 = "" Then TextBox8.SetFocus: Exit Sub With Sheets(ONGLET.Text) DL = .Cells(.Rows.Count, "A").End(xlUp).Row + 1 'première ligne vide de la colonne A (colonne à...
  5. job75

    XL 2016 Selection des onglets via combobox sans les afficher

    Vous avez oublié de mettre un point devant le 1er Cells => DL = .Cells... Application devant .Rows.Count est inutile. Par ailleurs ce n'est pas la macro ONGLET_Change qu'il faut mais celle du bouton;
  6. job75

    XL 2016 Selection des onglets via combobox sans les afficher

    Il faut préciser ce que l'on veut faire avec l'onglet : Private Sub ONGLET_Change() If ONGLET.ListIndex = -1 Then Exit Sub With Worksheets(ONGLET.Text) 'suite du code End With End Sub
  7. job75

    XL 2016 Selection des onglets via combobox sans les afficher

    mapomme vous a donné une solution : utiliser With/End With. Sinon utilisez une variable : Dim w As Worksheet Set w = ThisWorkbook.Worksheets(ONGLET.Text)
  8. job75

    XL 2016 formule matricelle

    Bonjour Sadahott, JHA, danielco, Le plus simple est d'utiliser un tableau auxiliaire, voyez le fichier joint. La limite 1000 est à adapter dans les formules. A+
  9. job75

    XL 2016 Selection des onglets via combobox sans les afficher

    Vous ne voulez pas activer la feuille mais vous l'activez avec Activate, ce n'est pas realiste :rolleyes:
  10. job75

    XL 2019 Ouvrir le fichier le plus récent d'un dossier dans VBA

    Cette remarque ne correspond à rien, voyez les résultats obtenus sur le fichier (3) !!!
  11. job75

    XL 2016 Recherchev sur plusieurs feuilles.

    Bonjour gorghrom, Roblochon, zebanx, Phil69970, Y a pas... Alors le mien avec : Private Sub Worksheet_Change(ByVal Target As Range) Application.ScreenUpdating = False Application.EnableEvents = False On Error Resume Next [A6].CurrentRegion.Clear Sheets(CStr([B1])).[A2].CurrentRegion.Copy [A6]...
  12. job75

    XL 2019 Condition VBA comprise entre 2 valeurs

    Bonjour LuanaDDC, Roblochon, Le VBA est ici tout à fait superflu, entrez les formules : - en J5 =SIERREUR(REPT("x";--SUBSTITUE(I5;"m";"")<12);"") - en K5 =SIERREUR(REPT("x";(--SUBSTITUE(I5;"m";"")>=12)*(--SUBSTITUE(I5;"m";"")<=35));"") - en L5...
  13. job75

    XL 2019 Suppression automatique, c'est possible ?

    Bonjour Muhadini, La macro dans le code de la feuille : Private Sub Worksheet_Change(ByVal Target As Range) ListObjects(1).Range.AutoFilter 6, "<>Terminée" End Sub A+
  14. job75

    XL 2019 Ouvrir le fichier le plus récent d'un dossier dans VBA

    Bonjour Cesar1275, Robert, le forum, C'est assez curieux mais bon voyez la macro ci-dessous. Il n'a jamais été question de coller des données dans la feuille Restauration qui n'est là que pour les doublons. Sub Importer() Dim d As Object, tablo, x$, v&, i&, F As Worksheet '---liste sans...
  15. job75

    XL 2016 Selection des onglets via combobox sans les afficher

    Bonjour le forum, @mapomme corrige vite cette vilaine erreur. A+
Haut Bas