Contenu récent par Dranreb

  1. Dranreb

    XL 2016 Recherche d'une date dans une plage de dates

    Notez que celle ci à peu près aussi :=TEXTE($F22-JOURSEM($F22;3);"jjj jj/mm/aaaa")&" — "&TEXTE($F22-JOURSEM($F22;3)+6;"jjj jj/mm/aaaa")
  2. Dranreb

    XL 2016 Recherche d'une date dans une plage de dates

    Bonjour. Cette formule sur 3 lignes à partir de la 22 le donne :=INDEX($A$3:$A$27;EQUIV($F22;$B$3:$B$27))
  3. Dranreb

    XL 2016 Simplification formule debile de 19Lignes (RESOLU)

    Alors préférons en 'BD_Formule'!E2, à propager sur 296 lignes :=SOMME.SI(Principal!$A$2:$A$35;$B2;Principal!$B$2:$B$35)
  4. Dranreb

    XL 2016 Relance de la discussion Trier 2 feuilles ou classeur

    Ah ouais, je n'ai pas reproduit la ligne des déclarations en tête. La voici :Dim TE(), LE&, TS(), LS&, Code As SsGr, Détail, C&, VLgNou(), VlgAnc(), Différent As Boolean, Cas As Byte, Rng As Range
  5. Dranreb

    XL 2016 Simplification formule debile de 19Lignes (RESOLU)

    C'est simple: pour savoir combien de fois il faut compter les doses de chaque MP on indique dedans combien de fois chaque Produit est spécifié dans l'autre feuille.
  6. Dranreb

    XL 2016 Relance de la discussion Trier 2 feuilles ou classeur

    Bonjour. Mettez devant :If Ls = 0 Then MsgBox "Aucun changement n'a été trouvé.", vbInformation, "Comparaison1": Exit Sub Pour information, dans le fichier que j'ai gardé la procédure se termine maintenant comme ça : Feuil3.Rows(2).Resize(1000).ClearContents If Ls = 0 Then MsgBox "Aucun...
  7. Dranreb

    XL 2016 Simplification formule debile de 19Lignes (RESOLU)

    Bonjour. Je crains qu'il ne faille insérer une colonne E en BD_Formule. En 'BD_Formule'!E2, à propager sur 462 lignes :=SIERREUR(INDEX(Principal!$B$2:$B$35;EQUIV($B2;Principal!$A$2:$A$35;0));0)En 'Principal'!G2, à propager sur 400 lignes...
  8. Dranreb

    XL 2019 Tableau dont les ligne variable

    C'est pareil pour le nombre de colonnes (ActiveSheet.ListObjects(1).ListColumns.Count)
  9. Dranreb

    XL 2019 Tableau dont les ligne variable

    Si'il s'agit toujours d'une plage ayant fait l'objet d'une mise sous forme de tableau, préférez une mise en forme conditionnelle qui ne l'affiche plus si c'est la même que celle de la cellule juste au dessus.
  10. Dranreb

    XL 2019 Tableau dont les ligne variable

    Si vous parlez d'un tableau Excel, donc couvert par un objet VBA de type ListeObject, je n'en vois pas bien l'intérêt puisqu'il suffit de tapez des choses dans la première ligne qui le suit pour qu'elle y soit automatiquement intégrée et qu'il en soit donc agrandi, et sont nombre de ligne est...
  11. Dranreb

    Recap diverses

    Bonjour. Pas de panique, ce n'est pas très grave. Il est simplement devenu subitement impossible de retransmettre à une autre procédure un ParamArray vide Il suffit donc de le tester devant toutes les invocations de cette procédures :If UBound(ColOrd) >= LBound(ColOrd) Then InterpréterParam...
  12. Dranreb

    copier/coller avec liaisons couleur

    Bonjour. Je m'aperçois que le problème n'avait pas été résolu exactement comme le souhaitait le demandeur. Alors, dans son classeur : Dans le module ThisWorkbook : Option Explicit Private ClnConsignes As New Collection Public Sub Consigne(ByVal R As Range, ByVal IC As Long) ClnConsignes.Add...
  13. Dranreb

    XL 2019 ProgressBar

    Remarque: Vous pouvez toujours me dire ce que vous ne comprenez pas dans les commentaires explicatifs d'utilisation des deux principales méthodes de l'UFmProg. En plus de L'UFmProg vous devez aussi glisser/déplacer le module MPlanificateur et le module de classe Planification. Il utilise en...
  14. Dranreb

    XL 2019 ProgressBar

    Bonjour. Joignez un modèle de classeur avec des traitements où vous souhaiteriez un barre d'avancement, une fois tout fait pour qu'ils soient les plus rapides possibles.
  15. Dranreb

    XL 2019 ProgressBar

    Un UFmProg facile à mettre en œuvre dans ce classeur.
Haut Bas