Contenu récent par Dranreb

  1. Dranreb

    XL 2010 Synchronisation de 3 combobox

    Bonjour. Cette ressource est faite pour vous : https://www.excel-downloads.com/resources/combobox-liees-et-controles-associes.1145/ Remarque: Il faudrait un tableau avec juste les 3 colonnes, en répétant sur chaque ligne les informations communes.
  2. Dranreb

    Autres Inserer une formule a base de LOG dans un TextBox

    Bonjour. Vouys pouvez aussi vous écrire : Function Log10(ByVal X as Double) As Double Const InvLog10 = 103910846 / 239263565 Log10 = Log(X) * InvLog10 End Function
  3. Dranreb

    Microsoft 365 VBA

    Like est un opérateur permettant de comparer un String avec un masque comportant des caractères jockers. Je crois deviner chez vous un désir de notions basiques qui vous permettrait de généraliser ensuite à plein d'autres choses. Mais pourriez vous exposer plus précisément les lacunes...
  4. Dranreb

    Microsoft 365 VBA

    Bonsoir. Pour que ça ne bronche ni à la compile ni à l'exécution, Sh doit être une variable objet, et Name doit en être une propriété.
  5. Dranreb

    XL 2016 Remplir Tableaux

    Bonsoir. Plus esthétique, je ne sais pas, mais 13 fois plus rapide : ActiveSheet.[B1:N1].Value = Array("CODE_PATIENT", "MOIS", "DATE VISITE", "PROTOCOLE", _ "NOUVEAU", "LIGNE", "AGE", "C_AGE", "SEXE", "DOTATION", "CTX", "STATUT", "ECHEANCE")
  6. Dranreb

    Résolu XL 2016 Indirect

    Mettez Formula1:="=INDIRECT(" & Target.Address & "&""_"")"
  7. Dranreb

    Résolu XL 2016 Indirect

    En mettant Formula1 et en doublant les guillemets ça marche chez moi :Sub Liste() With Sheets("Feuil1").Range("C2").Validation .Delete .Add Type:=xlValidateList, AlertStyle:=xlValidAlertStop, Operator:= _ xlBetween, Formula1:="=INDIRECT($C$1&""_"")" .IgnoreBlank...
  8. Dranreb

    Résolu XL 2016 Indirect

    Alors si on ne peut pas éviter à la fin du nom un '_' non spécifié dans la A7, j'ai aussi réussi à spécifier comme liste =INDIRECT($A$7&"_")
  9. Dranreb

    Résolu XL 2016 Indirect

    Je n'ai pas écris de macro. Ce serait plutôt à vous de joindre un classeur.
  10. Dranreb

    Résolu XL 2016 Indirect

    J'ai réussi à mettre une validation Liste avec comme formule =INDIRECT($A$7). Ça marche si A7 contient un nom valide ayant été défini.
  11. Dranreb

    Résolu XL 2016 Indirect

    Bonsoir. Ce qu'on ne peut surtout pas définir c'est un nom qui pourrait se confondre avec une adresse de cellule !
  12. Dranreb

    Résolu Résolu Eviter un #REF! lors de suppression d'un suite

    Bonjour. En H3, à propager sur 17 lignes :=SI(B3<>"";SI(DECALER(B3;-1;0)="";DECALER(C3;-1;0);DECALER(H3;-1;0));"")
  13. Dranreb

    Résolu fonction recherche valeur proche en vba

    Bonjour. Une fonction de recherche, là, qui utilise un Dictionary.
  14. Dranreb

    Résolu Microsoft 365 Condition entre 2 date

    Ouais mais il y a moins de parenthèses.
  15. Dranreb

    Résolu Microsoft 365 Condition entre 2 date

    Bonjour. Si c'est juste pour avoir une valeur d'erreur sur les valeurs négatives RACINE($B2)^2 irait aussi. Mais je chercherais quand même plutôt aussi une autre solution que celle ci de toute façon. Édition: peut être $B2/($B2>0) par exemple.
Haut Bas