Contenu récent par AtTheOne

  1. AtTheOne

    Microsoft 365 Déplacer ligne tableau grâce au SpinButton

    Bonjour @bibbip35 Euh ... C'est bien ce que ça fait non ? Regarde la procédure "Ini_LVw" : elle charge dans la ListView le tableau t_BDD en entier. Ensuite, on sélectionne une ligne dans cette listview, et avec le spinbutton on la déplace vers le haut ou vers le bas (dans la listview)...
  2. AtTheOne

    Microsoft 365 [VBA] macro pour cibler une cellule aléatoire et y coller une valeur

    Bonsoir @Casim Typ = 3 indique que la validation est de type liste Derlgn est le n° de la dernière ligne de la colonne contenant le rang dans la feuil1 (dans l'exemple la première colonne) Mais tu as trouvé par toi-même et c'est mieux ! Amicalement Alain
  3. AtTheOne

    Microsoft 365 [VBA] macro pour cibler une cellule aléatoire et y coller une valeur

    Bonjour à toutes et à tous, bonjour @Casim Si j'ai bien compris ta demande ... J'ai placé ta liste de validation dans une feuille "Tables" avec le nom défini "Chx_Code". J'ai traité l'événement Change de la "Feuil2" avec ce code : Private Sub Worksheet_Change(ByVal Target As Range) Dim...
  4. AtTheOne

    XL 2019 SommeProd en vba

    Bonjour @thespeedy20 Merci pour ta réponse. Peut-être mais j'avais utilisé la graphie de ton 1er post ou il n'y a pas de O majuscule ... Bon ce n'est pas bien grave, content que ça te convienne. A bientôt sur le forum, Amicalement Alain
  5. AtTheOne

    XL 2019 Copy contenu cellule sélectionnée dans cellule de sauvegarde du contenu

    Bonsoir à toutes & à tous, bonsoir @GDINFO Avec ce petit bout de code dans le code de la feuil1 Private Sub Worksheet_SelectionChange(ByVal Target As Range) If Target.Count = 1 And Not Intersect(Me.[A3:K3], Target) Is Nothing Then Me.[A1] = Target End If End Sub...
  6. AtTheOne

    XL 2016 distribution aléatoire

    Bonsoir à toutes & à tous, bonsoir @Seddiki_adz Peux-tu vérifier ta formule la partie en gras est erronée =INDEX($O$3:$O$37;MOD(COLONNES($A:A)+((LIGNES(S2$1:1))*6);35)+1) et faute d'un fichier exemple, dire dans quelles cellules il faut la placer ? Amicalement Alain
  7. AtTheOne

    XL 2019 SommeProd en vba

    Bonsoir à toutes & à tous, bonsoir @thespeedy20 Bon, allez je suis bien brave ... Les deux dernières formules sont un peu longues, j'ai fractionné. Un résumé pour les 3 formules : '1ère formule (voir post 2) TextBox7 = [IF(OR(Tarification!E15="Remboursement...
  8. AtTheOne

    Microsoft 365 Transcription formule en VBA

    Bonsoir à toutes & à tous, bonsoir @guenfood J'ai du jouer les Champollion avec ta formule : Tout d'abord =SI(D16="";"";... est-ce bien D16 et non D19 comme dans la suite de ta formule ? (j'ai gardé D16) Puis ... LIEN_HYPERTEXTE("mailto:"&Reference!G5;Reference!G5) ;... pas d'objet, pas de...
  9. AtTheOne

    XL 2019 SommeProd en vba

    Bonjour à toutes & à tous, bonjour @thespeedy20 Si ta formule : =SI(OU(E15="Remboursement ordinaire";E15="Bim-vipo");SOMMEPROD(NB.SI(B23:B27;Tarifs!Col_Codes)*(Tarifs!Col_RemOrdi))*E21;"") est correcte et renvoie le bon résultat, essaie ceci, sans espaces ni retour à la ligne ; (les crochets [...
  10. AtTheOne

    Microsoft 365 Déplacer ligne tableau grâce au SpinButton

    Bonjour à toutes & à tous, bonjour @bibbip35 Le but étant de montrer le fonctionnement du changement de l'ordre dans le tableau structuré avec le SpinButton du formulaire, je n'ai pas repris ton projet en totalité, j'ai fait l'exercice sur le tableau "t_BDD" extrait de ta pièce jointe en...
  11. AtTheOne

    XL 2019 recopie de cellules par rapport à une autre

    Bonjour @Rambaldy Je n'ai que mon téléphone jusqu'à dimanche soir. Pour te répondre ce n'est pas coton ! Avant d'afficher le bouton d'exécution je vérifie que les champs nécessaires sont renseignés, comme il y en a une vingtaine, plutôt que de faire autan de tests qu'il y a de champs à chaque...
  12. AtTheOne

    XL 2016 Interdiction des doublant

    Bonsoir @Seddiki_adz Il me semble que DRANREB a créé une ressource qui traite ce genre de problèmes, "tirage au sort avec contraintes" qui fonctionne pour des Compétitions avec des poules, clubs, arbitres ; Examen avec salles, professeurs, établissements, matières ... regarde sur le forum si tu...
  13. AtTheOne

    Autres 2 sujets: 1_Appliquer couleurs à partir de l'onglet "complément" sur calendrier. 2_ Créer 1 boucle d'mages JPEG en auto, type diapo sur Excel 2007

    Bonjour @Slavko.R Merci du retour, si tu le veux bien peux-tu marquer le post#13 comme étant la solution Bonne journée Amicalement Alain
  14. AtTheOne

    XL 2019 recopie de cellules par rapport à une autre

    Bonjour @Rambaldy Merci pour le retour et ton enthousiasme ! Si tu veux, pense à mettre le post #2 en solution. Bonne journée Amicalement Alain
  15. AtTheOne

    XL 2016 Code Transfer suivant condition

    Bonsoir @Seddiki_adz Merci pour le retour. Pour la solution, tu t'es trompé de post, c'est le #4 qu'il faut marquer ... A bientôt Alain